Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Go to most recent revision | Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
 
3
include /usr/share/cdbs/1/class/autotools.mk
4
include /usr/share/cdbs/1/rules/debhelper.mk
5
#include /usr/share/cdbs/1/rules/simple-patchsys.mk
6
# Currently no patches
7
#include /usr/share/cdbs/1/rules/dpatch.mk
8
 
9
# the used configure parameters for ./configure
10
DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \
11
	--with-pty --enable-tcp-forward --enable-x11-forward \
12
	--enable-agent-forward --enable-ipv6 --enable-utmp \
13
	--with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \
14
	--with-x XAUTH_PROGRAM=/usr/bin/xauth
15
 
16
DEB_INSTALL_CHANGELOGS_ALL := $(DEB_SRCDIR)/ChangeLog
17
DEB_INSTALL_DOCS_ALL := $(DEB_SRCDIR)/README
18
 
19
# cdbs options for lsh-client
20
DEB_INSTALL_MANPAGES_lsh-client := $(DEB_SRCDIR)/doc/lsh.1 \
21
	$(DEB_SRCDIR)/doc/lshg.1 debian/mans/lshc.1
22
DEB_INSTALL_DIRS_lsh-client := usr/bin
23
 
24
# cdbs options for lsh-server
25
DEB_INSTALL_MANPAGES_lsh-server := debian/mans/lsh-execuv.8 \
26
	debian/mans/lsh-pam-checkpw.8 \
27
	debian/mans/lsh-krb-checkpw.8 \
28
	debian/mans/lsh-server-config.8 \
29
	$(DEB_SRCDIR)/src/sftp/sftp-server.lsh.8 \
30
	$(DEB_SRCDIR)/doc/lshd.8
31
DEB_INSTALL_DIRS_lsh-server := usr/sbin etc/default
32
 
33
# cdbs options for lsh-utils
34
DEB_INSTALL_MANPAGES_lsh-utils := $(DEB_SRCDIR)/src/sftp/lsftp.1 \
35
	$(DEB_SRCDIR)/doc/lsh-authorize.1 \
36
	$(DEB_SRCDIR)/doc/lsh-decode-key.1 \
37
	$(DEB_SRCDIR)/doc/lsh-decrypt-key.1 \
38
	$(DEB_SRCDIR)/doc/lsh-export-key.1 \
39
	$(DEB_SRCDIR)/doc/lsh-make-seed.1 \
40
	$(DEB_SRCDIR)/doc/lsh-upgrade.1 \
41
	$(DEB_SRCDIR)/doc/lsh-upgrade-key.1 \
42
	$(DEB_SRCDIR)/doc/ssh-conv.1 \
43
	$(DEB_SRCDIR)/doc/lsh-keygen.1 \
44
	$(DEB_SRCDIR)/doc/lsh-writekey.1 \
45
	debian/mans/sexp-conv.lsh-utils.1 \
46
	debian/mans/srp-gen.1 \
47
	debian/mans/lcp.1
48
DEB_INSTALL_DOCS_lsh-utils := $(DEB_SRCDIR)/AUTHORS
49
DEB_INSTALL_DIRS_lsh-utils := usr/bin
50
 
51
# cdbs options for lsh-utils-doc
52
DEB_INSTALL_DOCS_lsh-utils-doc := $(DEB_SRCDIR)/FAQ $(DEB_SRCDIR)/NEWS \
53
	$(DEB_SRCDIR)/ChangeLog.1 \
54
	$(DEB_SRCDIR)/doc/HACKING $(DEB_SRCDIR)/doc/NOTES \
55
	$(DEB_SRCDIR)/doc/PORTS $(DEB_SRCDIR)/doc/TASKLIST \
56
	$(DEB_SRCDIR)/doc/TODO $(DEB_SRCDIR)/doc/configuration.txt \
57
	$(DEB_SRCDIR)/ChangeLog.1
58
DEB_INSTALL_MANPAGES_lsh-utils-doc := $(DEB_SRCDIR)/doc/DSA.5 \
59
	$(DEB_SRCDIR)/doc/SHA.5 \
60
	$(DEB_SRCDIR)/doc/SPKI.5 \
61
	$(DEB_SRCDIR)/doc/secsh.5
62
DEB_INSTALL_INFO_lsh-utils-doc := $(DEB_SRCDIR)/doc/lsh.info
63
 
64
reverse-config::
65
#	make distclean misses this
66
	rm -f src/nettle/machine.m4
67
 
68
cleanbuilddir::
69
	rm -f src/sftp/sftp-server.lsh.8
70
 
71
# override the default
72
install/lsh-utils::
73
	for i in \
74
		lsftp \
75
		lsftp \
76
		lsh-authorize \
77
		lsh-decode-key \
78
		lsh-export-key \
79
		lsh-keygen \
80
		lsh-make-seed \
81
		lsh-writekey \
82
		srp-gen \
83
		ssh-conv \
84
		lsh-decrypt-key \
85
		lsh-upgrade \
86
		lsh-upgrade-key \
87
		lcp \
88
	; do \
89
	mv debian/tmp/usr/bin/$$i debian/lsh-utils/usr/bin/$$i; done
90
#	Rename sexp-conv so that we can register it with the alternatives system
91
	mv debian/tmp/usr/bin/sexp-conv \
92
		debian/lsh-utils/usr/bin/sexp-conv.lsh-utils
93
 
94
install/lsh-server::
95
	for i in \
96
		lsh-execuv \
97
		lsh-pam-checkpw \
98
		lshd \
99
		lsh-krb-checkpw \
100
	; do \
101
	mv debian/tmp/usr/sbin/$$i debian/lsh-server/usr/sbin/$$i; done
102
#	sftp-server has a name conflict with the program of the same name in
103
#	the "ssh" package. Maybe I should talk to the openssh maintainer about
104
#	using alternatives?
105
	mv debian/tmp/usr/sbin/sftp-server \
106
		debian/lsh-server/usr/sbin/sftp-server.lsh
107
	cp -a $(DEB_SRCDIR)/src/sftp/sftp-server.8 \
108
		$(DEB_SRCDIR)/src/sftp/sftp-server.lsh.8
109
	install -m755 debian/scripts/lsh-server-config \
110
		debian/lsh-server/usr/sbin
111
 
112
install/lsh-client::
113
	mv debian/tmp/usr/bin/lsh   debian/lsh-client/usr/bin
114
	mv debian/tmp/usr/bin/lshg  debian/lsh-client/usr/bin
115
	install -m755 debian/scripts/lshc debian/lsh-client/usr/bin
116
 
117