Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 93 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 93 Rev 105
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
5
6
# Uncomment this to turn on verbose mode.
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
7
#export DH_VERBOSE=1
8
8
9
# These are used for cross-compiling and for saving the configure script
9
# These are used for cross-compiling and for saving the configure script
10
# from having to guess our platform (since we know it already)
10
# from having to guess our platform (since we know it already)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
13
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
16
else
16
else
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
18
endif
18
endif
19
19
20
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
20
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
21
ifneq (,$(parallel))
21
ifneq (,$(parallel))
22
jobsflag = -j$(parallel)
22
jobsflag = -j$(parallel)
23
endif
23
endif
24
24
25
config.status: configure.ac
25
config.status: configure.ac
26
	dh_testdir
26
	dh_testdir
27
	# Add here commands to configure the package.
27
	# Add here commands to configure the package.
28
	[ -d src/nettle-dontuse -a ! -d src/nettle ] || mv src/nettle src/nettle-dontuse
-
 
29
	dh_autoreconf
28
	dh_autoreconf
30
	./configure $(buildflags) \
29
	./configure $(buildflags) \
31
		    --prefix=/usr \
30
		    --prefix=/usr \
32
	            --disable-dependency-tracking \
31
	            --disable-dependency-tracking \
33
	            --enable-pam --enable-kerberos --enable-srp \
32
	            --enable-pam --enable-kerberos --enable-srp \
34
	            --with-pty --enable-tcp-forward --enable-x11-forward \
33
	            --with-pty --enable-tcp-forward --enable-x11-forward \
35
	            --enable-agent-forward --enable-ipv6 --enable-utmp \
34
	            --enable-agent-forward --enable-ipv6 --enable-utmp \
36
	            --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \
35
	            --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \
37
	            --with-x XAUTH_PROGRAM=/usr/bin/xauth \
36
	            --with-x XAUTH_PROGRAM=/usr/bin/xauth \
38
	            $(shell DEB_LDFLAGS_MAINT_PREPEND="-Wl,-z,defs -Wl,--as-needed" dpkg-buildflags --export=configure)
37
	            $(shell DEB_LDFLAGS_MAINT_PREPEND="-Wl,-z,defs -Wl,--as-needed" dpkg-buildflags --export=configure)
39
38
40
build: build-stamp
39
build: build-stamp
41
build-stamp:  config.status
40
build-stamp:  config.status
42
	dh_testdir
41
	dh_testdir
43
42
44
	# Add here commands to compile the package.
43
	# Add here commands to compile the package.
45
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
44
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
46
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
45
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
47
	$(MAKE) check
46
	$(MAKE) check
48
endif
47
endif
49
48
50
	touch build-stamp
49
	touch build-stamp
51
50
52
clean:
51
clean:
53
	dh_testdir
52
	dh_testdir
54
	dh_testroot
53
	dh_testroot
55
	rm -f build-stamp 
54
	rm -f build-stamp 
56
55
57
	# Add here commands to clean up after the build process.
56
	# Add here commands to clean up after the build process.
58
	[ ! -f Makefile ] || $(MAKE) distclean
57
	[ ! -f Makefile ] || $(MAKE) distclean
59
	dh_autoreconf_clean
58
	dh_autoreconf_clean
60
	dh_clean
59
	dh_clean
61
	[ -d src/nettle -a ! -d src/nettle-dontuse ] || mv src/nettle-dontuse src/nettle
-
 
62
60
63
install: build
61
install: build
64
	dh_testdir
62
	dh_testdir
65
	dh_testroot
63
	dh_testroot
66
	dh_prep
64
	dh_prep
67
	dh_installdirs
65
	dh_installdirs
68
66
69
	# Add here commands to install the package into debian/tmp
67
	# Add here commands to install the package into debian/tmp
70
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
68
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
71
69
72
build-indep build-arch: build
70
build-indep build-arch: build
73
71
74
# Build architecture-independent files here.
72
# Build architecture-independent files here.
75
binary-indep: build-indep install
73
binary-indep: build-indep install
76
	dh_testdir
74
	dh_testdir
77
	dh_testroot
75
	dh_testroot
78
	dh_install -i --sourcedir=debian/tmp
76
	dh_install -i --sourcedir=debian/tmp
79
	dh_link -i
77
	dh_link -i
80
	dh_installchangelogs -i ChangeLog
78
	dh_installchangelogs -i ChangeLog
81
	dh_installdocs -i -A README
79
	dh_installdocs -i -A README
82
	dh_installinfo -i
80
	dh_installinfo -i
83
	dh_installman -i
81
	dh_installman -i
84
	dh_installdebconf -i
82
	dh_installdebconf -i
85
	dh_compress -i
83
	dh_compress -i
86
	dh_fixperms -i
84
	dh_fixperms -i
87
	dh_makeshlibs -i
85
	dh_makeshlibs -i
88
	dh_installdeb -i
86
	dh_installdeb -i
89
	dh_shlibdeps -i
87
	dh_shlibdeps -i
90
	dh_gencontrol -i
88
	dh_gencontrol -i
91
	dh_md5sums -i
89
	dh_md5sums -i
92
	dh_builddeb -i
90
	dh_builddeb -i
93
91
94
# Build architecture-dependent files here.
92
# Build architecture-dependent files here.
95
binary-arch: build-arch install
93
binary-arch: build-arch install
96
	dh_testdir
94
	dh_testdir
97
	dh_testroot
95
	dh_testroot
98
	dh_install -a --sourcedir=debian/tmp
96
	dh_install -a --sourcedir=debian/tmp
99
	dh_link -a
97
	dh_link -a
100
	dh_installchangelogs -a ChangeLog
98
	dh_installchangelogs -a ChangeLog
101
	dh_installdocs -a -A README
99
	dh_installdocs -a -A README
102
	dh_installexamples -a
100
	dh_installexamples -a
103
	dh_installman -a
101
	dh_installman -a
104
	dh_installinit -a
102
	dh_installinit -a
105
	dh_installdebconf -a
103
	dh_installdebconf -a
106
	dh_strip -a
104
	dh_strip -a
107
	dh_compress -a
105
	dh_compress -a
108
	dh_fixperms -a
106
	dh_fixperms -a
109
	dh_makeshlibs -a
107
	dh_makeshlibs -a
110
	dh_installdeb -a
108
	dh_installdeb -a
111
	dh_shlibdeps -a
109
	dh_shlibdeps -a
112
	dh_gencontrol -a
110
	dh_gencontrol -a
113
	dh_md5sums -a
111
	dh_md5sums -a
114
	dh_builddeb -a
112
	dh_builddeb -a
115
113
116
binary: binary-arch binary-indep
114
binary: binary-arch binary-indep
117
.PHONY: build-indep build-arch build clean clean-patched binary-indep binary-arch binary install
115
.PHONY: build-indep build-arch build clean clean-patched binary-indep binary-arch binary install