Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 8 | Rev 26 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/usr/bin/make -f

include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/dpatch.mk

# the used configure parameters for ./configure
DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \
        --with-pty --enable-tcp-forward --enable-x11-forward \
        --enable-agent-forward --enable-ipv6 --enable-utmp \
        --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \
        --with-x XAUTH_PROGRAM=/usr/bin/xauth

DEB_INSTALL_CHANGELOGS_ALL := ChangeLog
DEB_INSTALL_DOCS_ALL := README
DEB_DH_INSTALL_SOURCEDIR := debian/tmp

LDFLAGS += -Wl,--as-needed -Wl,--no-undefined

common-install-arch::
        install -m755 debian/scripts/lsh-server-config \
                debian/tmp/usr/sbin