Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
124 magnus 1
Description: Include limits.h in camellia.absorb.c
2
 As the comment near the bottom of config.h.in says, source files
3
 using the HAVE_NATIVE_64_BIT macro needs to include limits.h in case
4
 the arch is 64-bit although the __x86_64__ or __arch64__ macros are
5
 not defined.
6
Forwarded: yes
7
 
8
--- a/camellia-absorb.c
9
+++ b/camellia-absorb.c
10
@@ -47,6 +47,8 @@
11
 # include "config.h"
12
 #endif
13
 
14
+#include <limits.h>
15
+
16
 #include "camellia-internal.h"
17
 
18
 #include "macros.h"