Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

Description: Include limits.h in camellia.absorb.c
 As the comment near the bottom of config.h.in says, source files
 using the HAVE_NATIVE_64_BIT macro needs to include limits.h in case
 the arch is 64-bit although the __x86_64__ or __arch64__ macros are
 not defined.
Forwarded: yes

--- a/camellia-absorb.c
+++ b/camellia-absorb.c
@@ -47,6 +47,8 @@
 # include "config.h"
 #endif
 
+#include <limits.h>
+
 #include "camellia-internal.h"
 
 #include "macros.h"