Rev 15 | Rev 42 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 15 | Rev 35 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | include /usr/share/dpatch/dpatch.make |
8 | include /usr/share/dpatch/dpatch.make |
9 | 9 | ||
10 | # These are used for cross-compiling and for saving the configure script |
10 | # These are used for cross-compiling and for saving the configure script |
11 | # from having to guess our platform (since we know it already) |
11 | # from having to guess our platform (since we know it already) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
17 | 17 | ||
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | CFLAGS += -O0 |
19 | CFLAGS += -O0 |
20 | else |
20 | else |
21 | CFLAGS += -O2 |
21 | CFLAGS += -O2 |
22 | endif |
22 | endif |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | INSTALL_PROGRAM += -s |
24 | INSTALL_PROGRAM += -s |
25 | endif |
25 | endif |
26 | 26 | ||
27 | config.status: ${DPATCH_STAMPFN} configure |
27 | config.status: ${DPATCH_STAMPFN} configure |
28 | dh_testdir |
28 | dh_testdir |
29 | # Add here commands to configure the package. |
29 | # Add here commands to configure the package. |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --prefix=/usr \ |
32 | --prefix=/usr \ |
33 | --mandir=\$${prefix}/share/man \ |
33 | --mandir=\$${prefix}/share/man \ |
34 | --infodir=\$${prefix}/share/info \ |
34 | --infodir=\$${prefix}/share/info \ |
35 | --enable-shared \ |
35 | --enable-shared \ |
36 | --disable-dependency-tracking |
36 | --disable-dependency-tracking |
37 | 37 | ||
38 | 38 | ||
39 | build: build-stamp |
39 | build: build-stamp |
40 | build-stamp: config.status |
40 | build-stamp: config.status |
41 | dh_testdir |
41 | dh_testdir |
42 | 42 | ||
43 | # Add here commands to compile the package. |
43 | # Add here commands to compile the package. |
44 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
44 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
45 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
45 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
46 | $(MAKE) check |
46 | $(MAKE) check |
47 | endif |
47 | endif |
48 | 48 | ||
49 | touch build-stamp |
49 | touch build-stamp |
50 | 50 | ||
51 | clean: clean-patched unpatch |
51 | clean: clean-patched unpatch |
52 | dh_clean |
52 | dh_clean |
53 | 53 | ||
54 | clean-patched: |
54 | clean-patched: |
55 | dh_testdir |
55 | dh_testdir |
56 | dh_testroot |
56 | dh_testroot |
57 | rm -f build-stamp |
57 | rm -f build-stamp |
58 | 58 | ||
59 | # Add here commands to clean up after the build process. |
59 | # Add here commands to clean up after the build process. |
60 | -$(MAKE) distclean |
60 | [ ! -f Makefile ] || $(MAKE) distclean |
61 | 61 | ||
62 | install: build |
62 | install: build |
63 | dh_testdir |
63 | dh_testdir |
64 | dh_testroot |
64 | dh_testroot |
65 | dh_clean -k |
65 | dh_clean -k |
66 | dh_installdirs |
66 | dh_installdirs |
67 | 67 | ||
68 | # Add here commands to install the package into debian/tmp |
68 | # Add here commands to install the package into debian/tmp |
69 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
69 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
70 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
70 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
71 | 71 | ||
72 | # Build architecture-independent files here. |
72 | # Build architecture-independent files here. |
73 | binary-indep: build install |
73 | binary-indep: build install |
74 | # We have nothing to do by default. |
74 | # We have nothing to do by default. |
75 | 75 | ||
76 | # Build architecture-dependent files here. |
76 | # Build architecture-dependent files here. |
77 | binary-arch: build install |
77 | binary-arch: build install |
78 | dh_testdir |
78 | dh_testdir |
79 | dh_testroot |
79 | dh_testroot |
80 | dh_install --sourcedir=debian/tmp |
80 | dh_install --sourcedir=debian/tmp |
81 | dh_installchangelogs ChangeLog |
81 | dh_installchangelogs ChangeLog |
82 | dh_installdocs |
82 | dh_installdocs |
83 | dh_installexamples |
83 | dh_installexamples |
84 | dh_installinfo |
84 | dh_installinfo |
85 | dh_installman |
85 | dh_installman |
86 | dh_link |
86 | dh_link |
87 | dh_strip |
87 | dh_strip |
88 | dh_compress -X.pdf |
88 | dh_compress -X.pdf |
89 | dh_fixperms |
89 | dh_fixperms |
90 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
90 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
91 | dh_installdeb |
91 | dh_installdeb |
92 | dh_shlibdeps |
92 | dh_shlibdeps |
93 | dh_gencontrol |
93 | dh_gencontrol |
94 | dh_md5sums |
94 | dh_md5sums |
95 | dh_builddeb |
95 | dh_builddeb |
96 | 96 | ||
97 | binary: binary-indep binary-arch |
97 | binary: binary-indep binary-arch |
98 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |
98 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |