Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
26 magnus 1
#! /bin/sh -e
2
## config.dpatch
3
## Ralf Treinen <treinen@debian.org>
4
##
5
## All lines beginning with `## DP:' are a description of the patch.
6
## DP: replace all config.{guess,sub} by the vesion installed in
7
## DP: /usr/share/misc
8
 
9
dpatch_patch ()
10
{
11
	find . -name config.guess -o -name config.sub \
12
	 	| tar cf debian/patched/config.guess+sub.tar -T -
13
	find . -name config.guess \
14
		-exec ln -sf /usr/share/misc/config.guess '{}' \;
15
	find . -name config.sub \
16
		-exec ln -sf /usr/share/misc/config.sub '{}' \;
17
}
18
 
19
dpatch_unpatch ()
20
{
21
	tar xf debian/patched/config.guess+sub.tar
22
}
23
 
24
DPATCH_LIB_NO_DEFAULT=1
25
 
26
. /usr/share/dpatch/dpatch.lib.sh
27
 
28
# arch-tag: 8a610a57-687b-4395-8ff2-79265c0a4eb3