Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/bin/sh
2
## 01_autotools_files.dpatch by Magnus Holmgren <magnus@kibibyte.se>
3
##
4
## DP: Copy in updated config.sub and config.guess from autotools-dev
5
 
6
set -e
7
 
8
dpatch_patch() {
9
    for f in config.sub config.guess; do
4 magnus 10
        if ! test -e $f.dp-orig; then
11
            mv $f $f.dp-orig
3 magnus 12
            cp --remove-destination /usr/share/misc/$f .
13
        fi
14
    done
15
}
16
 
17
dpatch_unpatch() {
18
    for f in config.sub config.guess; do
4 magnus 19
        if test -e $f.dp-orig; then
20
            mv -f $f.dp-orig $f
3 magnus 21
        fi
22
    done
23
}
24
 
25
 
26
DPATCH_LIB_NO_DEFAULT=1
27
 
28
. /usr/share/dpatch/dpatch.lib.sh