Rev 9 | Rev 16 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 9 | Rev 14 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | include /usr/share/dpatch/dpatch.make |
8 | include /usr/share/dpatch/dpatch.make |
9 | 9 | ||
10 | # These are used for cross-compiling and for saving the configure script |
10 | # These are used for cross-compiling and for saving the configure script |
11 | # from having to guess our platform (since we know it already) |
11 | # from having to guess our platform (since we know it already) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
17 | 17 | ||
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | CFLAGS += -O0 |
19 | CFLAGS += -O0 |
20 | else |
20 | else |
21 | CFLAGS += -O2 |
21 | CFLAGS += -O2 |
22 | endif |
22 | endif |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | INSTALL_PROGRAM += -s |
24 | INSTALL_PROGRAM += -s |
25 | endif |
25 | endif |
26 | 26 | ||
27 | config.status: ${DPATCH_STAMPFN} configure |
27 | config.status: ${DPATCH_STAMPFN} configure |
28 | dh_testdir |
28 | dh_testdir |
29 | # Add here commands to configure the package. |
29 | # Add here commands to configure the package. |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --prefix=/usr \ |
32 | --prefix=/usr \ |
33 | --mandir=\$${prefix}/share/man \ |
33 | --mandir=\$${prefix}/share/man \ |
34 | --infodir=\$${prefix}/share/info \ |
34 | --infodir=\$${prefix}/share/info \ |
35 | --enable-shared \ |
35 | --enable-shared \ |
36 | --disable-dependency-tracking |
36 | --disable-dependency-tracking |
37 | 37 | ||
38 | 38 | ||
39 | build: build-stamp |
39 | build: build-stamp |
40 | build-stamp: config.status |
40 | build-stamp: config.status |
41 | dh_testdir |
41 | dh_testdir |
42 | 42 | ||
43 | # Add here commands to compile the package. |
43 | # Add here commands to compile the package. |
44 | $(MAKE) |
44 | $(MAKE) |
45 | 45 | ||
46 | touch build-stamp |
46 | touch build-stamp |
47 | 47 | ||
48 | clean: clean-patched unpatch |
48 | clean: clean-patched unpatch |
49 | dh_clean |
49 | dh_clean |
50 | 50 | ||
51 | clean-patched: |
51 | clean-patched: |
52 | dh_testdir |
52 | dh_testdir |
53 | dh_testroot |
53 | dh_testroot |
54 | rm -f build-stamp |
54 | rm -f build-stamp |
55 | 55 | ||
56 | # Add here commands to clean up after the build process. |
56 | # Add here commands to clean up after the build process. |
57 | -$(MAKE) distclean |
57 | -$(MAKE) distclean |
58 | 58 | ||
59 | install: build |
59 | install: build |
60 | dh_testdir |
60 | dh_testdir |
61 | dh_testroot |
61 | dh_testroot |
62 | dh_clean -k |
62 | dh_clean -k |
63 | dh_installdirs |
63 | dh_installdirs |
64 | 64 | ||
65 | # Add here commands to install the package into debian/tmp |
65 | # Add here commands to install the package into debian/tmp |
66 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
66 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
67 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
67 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
68 | 68 | ||
69 | # Build architecture-independent files here. |
69 | # Build architecture-independent files here. |
70 | binary-indep: build install |
70 | binary-indep: build install |
71 | # We have nothing to do by default. |
71 | # We have nothing to do by default. |
72 | 72 | ||
73 | # Build architecture-dependent files here. |
73 | # Build architecture-dependent files here. |
74 | binary-arch: build install |
74 | binary-arch: build install |
75 | dh_testdir |
75 | dh_testdir |
76 | dh_testroot |
76 | dh_testroot |
77 | dh_movefiles |
77 | dh_movefiles |
78 | dh_installchangelogs ChangeLog |
78 | dh_installchangelogs ChangeLog |
79 | dh_installdocs |
79 | dh_installdocs |
80 | dh_installexamples |
80 | dh_installexamples |
81 | dh_installinfo |
81 | dh_installinfo |
82 | dh_installman |
82 | dh_installman |
83 | dh_link |
83 | dh_link |
84 | dh_strip |
84 | dh_strip |
85 | dh_compress |
85 | dh_compress |
86 | dh_fixperms |
86 | dh_fixperms |
87 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
87 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
88 | dh_installdeb |
88 | dh_installdeb |
89 | dh_shlibdeps |
89 | dh_shlibdeps |
90 | dh_gencontrol |
90 | dh_gencontrol |
91 | dh_md5sums |
91 | dh_md5sums |
92 | dh_builddeb |
92 | dh_builddeb |
93 | 93 | ||
94 | binary: binary-indep binary-arch |
94 | binary: binary-indep binary-arch |
95 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |
95 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |