Rev 14 | Rev 21 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 14 | Rev 16 | ||
---|---|---|---|
Line 12... | Line 12... | ||
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
- | 17 | LDFLAGS = -Wl,--as-needed |
|
17 | 18 | ||
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | CFLAGS += -O0 |
20 | CFLAGS += -O0 |
20 | else |
21 | else |
21 | CFLAGS += -O2 |
22 | CFLAGS += -O2 |
Line 25... | Line 26... | ||
25 | endif |
26 | endif |
26 | 27 | ||
27 | config.status: ${DPATCH_STAMPFN} configure |
28 | config.status: ${DPATCH_STAMPFN} configure |
28 | dh_testdir |
29 | dh_testdir |
29 | # Add here commands to configure the package. |
30 | # Add here commands to configure the package. |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --prefix=/usr \ |
33 | --prefix=/usr \ |
33 | --mandir=\$${prefix}/share/man \ |
34 | --mandir=\$${prefix}/share/man \ |
34 | --infodir=\$${prefix}/share/info \ |
35 | --infodir=\$${prefix}/share/info \ |
35 | --enable-shared \ |
36 | --enable-shared \ |
36 | --disable-dependency-tracking |
37 | --disable-dependency-tracking \ |
- | 38 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" |
|
37 | 39 | ||
38 | 40 | ||
39 | build: build-stamp |
41 | build: build-stamp |
40 | build-stamp: config.status |
42 | build-stamp: config.status |
41 | dh_testdir |
43 | dh_testdir |
42 | 44 | ||
43 | # Add here commands to compile the package. |
45 | # Add here commands to compile the package. |
- | 46 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
|
- | 47 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
|
44 | $(MAKE) |
48 | $(MAKE) check |
- | 49 | endif |
|
45 | 50 | ||
46 | touch build-stamp |
51 | touch build-stamp |
47 | 52 | ||
48 | clean: clean-patched unpatch |
53 | clean: clean-patched unpatch |
49 | dh_clean |
54 | dh_clean |
Line 62... | Line 67... | ||
62 | dh_clean -k |
67 | dh_clean -k |
63 | dh_installdirs |
68 | dh_installdirs |
64 | 69 | ||
65 | # Add here commands to install the package into debian/tmp |
70 | # Add here commands to install the package into debian/tmp |
66 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
71 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
67 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
72 | # mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
68 | 73 | ||
69 | # Build architecture-independent files here. |
74 | # Build architecture-independent files here. |
70 | binary-indep: build install |
75 | binary-indep: build install |
71 | # We have nothing to do by default. |
76 | # We have nothing to do by default. |
72 | 77 | ||
73 | # Build architecture-dependent files here. |
78 | # Build architecture-dependent files here. |
74 | binary-arch: build install |
79 | binary-arch: build install |
75 | dh_testdir |
80 | dh_testdir |
76 | dh_testroot |
81 | dh_testroot |
- | 82 | dh_install --sourcedir=debian/tmp |
|
77 | dh_movefiles |
83 | dh_link |
78 | dh_installchangelogs ChangeLog |
84 | dh_installchangelogs ChangeLog |
79 | dh_installdocs |
85 | dh_installdocs |
80 | dh_installexamples |
86 | dh_installexamples |
81 | dh_installinfo |
87 | dh_installinfo |
82 | dh_installman |
88 | dh_installman |
83 | dh_link |
- | |
84 | dh_strip |
89 | dh_strip |
85 | dh_compress |
90 | dh_compress -X.pdf |
86 | dh_fixperms |
91 | dh_fixperms |
87 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
92 | dh_makeshlibs #-V 'libnettle2 (>= 1.15)' |
88 | dh_installdeb |
93 | dh_installdeb |
89 | dh_shlibdeps |
94 | dh_shlibdeps |
90 | dh_gencontrol |
95 | dh_gencontrol |
91 | dh_md5sums |
96 | dh_md5sums |
92 | dh_builddeb |
97 | dh_builddeb |