Rev 6 | Rev 9 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 6 | Rev 8 | ||
---|---|---|---|
Line 22... | Line 22... | ||
22 | endif |
22 | endif |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | INSTALL_PROGRAM += -s |
24 | INSTALL_PROGRAM += -s |
25 | endif |
25 | endif |
26 | 26 | ||
27 | # shared library versions, option 1 |
- | |
28 | version=2.0.5 |
- | |
29 | major=2 |
- | |
30 | # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so |
- | |
31 | #version=`ls src/.libs/lib*.so.* | \ |
- | |
32 | # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'` |
- | |
33 | #major=`ls src/.libs/lib*.so.* | \ |
- | |
34 | # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'` |
- | |
35 | - | ||
36 | config.status: ${DPATCH_STAMPFN} configure |
27 | config.status: ${DPATCH_STAMPFN} configure |
37 | dh_testdir |
28 | dh_testdir |
38 | # Add here commands to configure the package. |
29 | # Add here commands to configure the package. |
39 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
40 | --build=$(DEB_BUILD_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
Line 93... | Line 84... | ||
93 | dh_strip |
84 | dh_strip |
94 | dh_compress |
85 | dh_compress |
95 | dh_fixperms |
86 | dh_fixperms |
96 | dh_makeshlibs |
87 | dh_makeshlibs |
97 | dh_installdeb |
88 | dh_installdeb |
98 | dh_shlibdeps |
89 | dh_shlibdeps -V 'libnettle2 (>= 1.15)' |
99 | dh_gencontrol |
90 | dh_gencontrol |
100 | dh_md5sums |
91 | dh_md5sums |
101 | dh_builddeb |
92 | dh_builddeb |
102 | 93 | ||
103 | binary: binary-indep binary-arch |
94 | binary: binary-indep binary-arch |