Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 54 | Rev 65 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 54 Rev 64
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
5
6
# Uncomment this to turn on verbose mode.
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
7
#export DH_VERBOSE=1
8
include /usr/share/dpatch/dpatch.make
-
 
9
8
10
# These are used for cross-compiling and for saving the configure script
9
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
10
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
13
15
-
 
16
CFLAGS = -Wall -g
14
CFLAGS = -Wall -g
17
LDFLAGS = -Wl,--as-needed
15
LDFLAGS = -Wl,--as-needed
18
16
19
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
17
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
20
	CFLAGS += -O0
18
	CFLAGS += -O0
21
else
19
else
22
	CFLAGS += -O2
20
	CFLAGS += -O2
23
endif
21
endif
24
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
22
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
25
	INSTALL_PROGRAM += -s
23
	INSTALL_PROGRAM += -s
26
endif
24
endif
27
25
28
config.status: ${DPATCH_STAMPFN} configure
26
config.status: configure
29
	dh_testdir
27
	dh_testdir
30
	# Add here commands to configure the package.
28
	# Add here commands to configure the package.
-
 
29
	dh_autotools-dev_updateconfig
31
	./configure --host=$(DEB_HOST_GNU_TYPE) \
30
	./configure --host=$(DEB_HOST_GNU_TYPE) \
32
		    --build=$(DEB_BUILD_GNU_TYPE) \
31
		    --build=$(DEB_BUILD_GNU_TYPE) \
33
		    --prefix=/usr \
32
		    --prefix=/usr \
34
	            --mandir=\$${prefix}/share/man \
33
	            --mandir=\$${prefix}/share/man \
35
	            --infodir=\$${prefix}/share/info \
34
	            --infodir=\$${prefix}/share/info \
36
	            --enable-shared \
35
	            --enable-shared \
37
	            --disable-dependency-tracking \
36
	            --disable-dependency-tracking \
38
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
37
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
39
38
40
39
41
build: build-stamp
40
build: build-stamp
42
build-stamp:  config.status
41
build-stamp:  config.status
43
	dh_testdir
42
	dh_testdir
44
43
45
	# Add here commands to compile the package.
44
	# Add here commands to compile the package.
46
	$(MAKE) MAKEINFO='makeinfo --enable-encoding'
45
	$(MAKE) MAKEINFO='makeinfo --enable-encoding'
47
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
46
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
48
	$(MAKE) check
47
	$(MAKE) check
49
endif
48
endif
50
49
51
	touch build-stamp
50
	touch build-stamp
52
51
53
clean: clean-patched unpatch
-
 
54
	dh_clean
52
clean:
55
-
 
56
clean-patched:
-
 
57
	dh_testdir
53
	dh_testdir
58
	dh_testroot
54
	dh_testroot
59
	rm -f build-stamp 
55
	rm -f build-stamp 
60
56
61
	# Add here commands to clean up after the build process.
57
	# Add here commands to clean up after the build process.
62
	[ ! -f Makefile ] || $(MAKE) distclean
58
	[ ! -f Makefile ] || $(MAKE) distclean
-
 
59
	dh_autotools-dev_restoreconfig
-
 
60
	dh_clean
63
61
64
install: build
62
install: build
65
	dh_testdir
63
	dh_testdir
66
	dh_testroot
64
	dh_testroot
67
	dh_clean -k 
65
	dh_clean -k 
68
	dh_installdirs
66
	dh_installdirs
69
67
70
	# Add here commands to install the package into debian/tmp
68
	# Add here commands to install the package into debian/tmp
71
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
69
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
72
70
73
# Build architecture-independent files here.
71
# Build architecture-independent files here.
74
binary-indep:
72
binary-indep:
75
# Nothing to do
73
# Nothing to do
76
74
77
# Build architecture-dependent files here.
75
# Build architecture-dependent files here.
78
binary-arch: build install
76
binary-arch: build install
79
	dh_testdir
77
	dh_testdir
80
	dh_testroot
78
	dh_testroot
81
	dh_install -a --sourcedir=debian/tmp
79
	dh_install -a --sourcedir=debian/tmp
82
	dh_link -a
80
	dh_link -a
83
	dh_installchangelogs -a ChangeLog
81
	dh_installchangelogs -a ChangeLog
84
	dh_installdocs -a
82
	dh_installdocs -a
85
	dh_installexamples -a
83
	dh_installexamples -a
86
	dh_installinfo -a
84
	dh_installinfo -a
87
	dh_installman -a
85
	dh_installman -a
88
	dh_strip -a --dbg-package=nettle-dbg
86
	dh_strip -a --dbg-package=nettle-dbg
89
	dh_compress -a -X.pdf
87
	dh_compress -a -X.pdf
90
	dh_fixperms -a
88
	dh_fixperms -a
91
	dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
89
	dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
92
	dh_installdeb -a
90
	dh_installdeb -a
93
	dh_shlibdeps -a
91
	dh_shlibdeps -a
94
	dh_gencontrol -a
92
	dh_gencontrol -a
95
	dh_md5sums -a
93
	dh_md5sums -a
96
	dh_builddeb -a
94
	dh_builddeb -a
97
95
98
binary: binary-arch
96
binary: binary-arch
99
.PHONY: build clean clean-patched binary-indep binary-arch binary install
97
.PHONY: build clean clean-patched binary-indep binary-arch binary install