Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh
2
# postinst script for pike7.6
3
#
4
# see: dh_installdeb(1)
5
#
6
# $Id: postinst,v 1.9 2004/04/30 17:12:43 grendel Exp $
7
#
8
 
9
set -e
10
 
11
PIKE=7.6
12
PIKEBIN=pike${PIKE}
13
 
14
# summary of how this script can be called:
15
#        * <postinst> `configure' <most-recently-configured-version>
16
#        * <old-postinst> `abort-upgrade' <new version>
17
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
18
#          <new-version>
19
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
20
#          <failed-install-package> <version> `removing'
21
#          <conflicting-package> <version>
22
# for details, see http://www.debian.org/doc/debian-policy/ or
23
# the debian-policy package
24
#
25
# quoting from the policy:
26
#     Any necessary prompting should almost always be confined to the
27
#     post-installation script, and should be protected with a conditional
28
#     so that unnecessary prompting doesn't happen if a package's
29
#     installation fails and the `postinst' is called with `abort-upgrade',
30
#     `abort-remove' or `abort-deconfigure'.
31
 
32
case "$1" in
33
    configure)
34
    /usr/sbin/update-alternatives --install /usr/bin/sexp-conv sexp-conv /usr/bin/sexp-conv.nettle 10 \
35
    --slave /usr/share/man/man1/sexp-conv.1.gz sexp-conv.1.gz /usr/share/man/man1/sexp-conv.nettle.1.gz
36
    ;;
37
 
38
    abort-upgrade|abort-remove|abort-deconfigure)
39
 
40
    ;;
41
 
42
    *)
43
        echo "postinst called with unknown argument \`$1'" >&2
44
        exit 1
45
    ;;
46
esac
47
 
48
# dh_installdeb will replace this with shell code automatically
49
# generated by other debhelper scripts.
50
 
51
#DEBHELPER#
52
 
53
exit 0