Rev 3 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 4 | ||
---|---|---|---|
Line 5... | Line 5... | ||
5 | 5 | ||
6 | set -e |
6 | set -e |
7 | 7 | ||
8 | dpatch_patch() { |
8 | dpatch_patch() { |
9 | for f in config.sub config.guess; do |
9 | for f in config.sub config.guess; do |
10 | if ! test -e $f.orig; then |
10 | if ! test -e $f.dp-orig; then |
11 | mv $f $f.orig |
11 | mv $f $f.dp-orig |
12 | cp --remove-destination /usr/share/misc/$f . |
12 | cp --remove-destination /usr/share/misc/$f . |
13 | fi |
13 | fi |
14 | done |
14 | done |
15 | } |
15 | } |
16 | 16 | ||
17 | dpatch_unpatch() { |
17 | dpatch_unpatch() { |
18 | for f in config.sub config.guess; do |
18 | for f in config.sub config.guess; do |
19 | if test -e $f.orig; then |
19 | if test -e $f.dp-orig; then |
20 | mv -f $f.orig $f |
20 | mv -f $f.dp-orig $f |
21 | fi |
21 | fi |
22 | done |
22 | done |
23 | } |
23 | } |
24 | 24 | ||
25 | 25 |