Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 147 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
144 magnus 1
--- a/aclocal.m4
2
+++ b/aclocal.m4
3
@@ -856,11 +856,7 @@ AC_CHECK_TYPE(intmax_t,,,[#include <$ac_
4
 
5
 fi # shortcircut to system "stdint.h"
6
 # ------------------ PREPARE VARIABLES ------------------------------
7
-if test "$GCC" = "yes" ; then
8
-ac_cv_stdint_message="using gnu compiler "`$CC --version | head -1` 
9
-else
10
 ac_cv_stdint_message="using $CC"
11
-fi
12
 
13
 AC_MSG_RESULT([make use of $ac_cv_header_stdint in $ac_stdint_h dnl
14
 $ac_cv_stdint_result])
15
--- a/configure
16
+++ b/configure
147 magnus 17
@@ -6471,11 +6471,7 @@ fi
144 magnus 18
 
19
 fi # shortcircut to system "stdint.h"
20
 # ------------------ PREPARE VARIABLES ------------------------------
21
-if test "$GCC" = "yes" ; then
22
-ac_cv_stdint_message="using gnu compiler "`$CC --version | head -1`
23
-else
24
 ac_cv_stdint_message="using $CC"
25
-fi
26
 
27
 { $as_echo "$as_me:${as_lineno-$LINENO}: result: make use of $ac_cv_header_stdint in $ac_stdint_h $ac_cv_stdint_result" >&5
28
 $as_echo "make use of $ac_cv_header_stdint in $ac_stdint_h $ac_cv_stdint_result" >&6; }
163 magnus 29
--- a/version.h.in
30
+++ b/version.h.in
31
@@ -48,7 +48,8 @@ extern "C" {
32
 /* We need a preprocessor constant for GMP_NUMB_BITS, simply using
33
    sizeof(mp_limb_t) * CHAR_BIT is not good enough. */
34
 #if NETTLE_USE_MINI_GMP
35
-# define GMP_NUMB_BITS @GMP_NUMB_BITS@
36
+#  include <limits.h>
37
+#  define GMP_NUMB_BITS (__SIZEOF_LONG__ * CHAR_BIT)
38
 #endif
39
 
40
 int