Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
57 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## rsa2sexp_algorithm_name.dpatch by Magnus Holmgren <holmgren@debian.org>
3
##
4
## DP: Use a default algorithm name that LSH understands.
5
 
6
@DPATCH@
7
diff -urNad trunk~/rsa2sexp.c trunk/rsa2sexp.c
8
--- trunk~/rsa2sexp.c	2009-06-08 20:27:10.000000000 +0200
9
+++ trunk/rsa2sexp.c	2009-10-11 23:11:28.000000000 +0200
10
@@ -37,7 +37,7 @@
11
 		    const struct rsa_private_key *priv)
12
 {
13
   if (!algorithm_name)
14
-    algorithm_name = "rsa";
15
+    algorithm_name = "rsa-pkcs1";
16
 
17
   if (priv)
18
     return sexp_format(buffer,
19
diff -urNad trunk~/testsuite/rsa2sexp-test.c trunk/testsuite/rsa2sexp-test.c
20
--- trunk~/testsuite/rsa2sexp-test.c	2009-06-08 20:27:12.000000000 +0200
21
+++ trunk/testsuite/rsa2sexp-test.c	2009-10-11 23:11:56.000000000 +0200
22
@@ -92,13 +92,13 @@
23
       print_hex(buffer.size, buffer.contents);
24
     }
25
   ASSERT(MEMEQH(buffer.size, buffer.contents,
26
-		"2831303a7075626c69632d6b65792833"
27
-		"3a72736128313a6e36333a085c340898"
28
-		"9acae4faec3cbbad91c90d34c1d259cd"
29
-		"74121a36f38b0b51424a9b2be514a043"
30
-		"77113a6cdafe79dd7d5f2ecc8b5e9661"
31
-		"189b86a7b22239907c252928313a6534"
32
-		"3a36ad4b1d292929"));
33
+		"2831303a7075626c69632d6b65792839"
34
+		"3a7273612d706b63733128313a6e3633"
35
+		"3a085c3408989acae4faec3cbbad91c9"
36
+		"0d34c1d259cd74121a36f38b0b51424a"
37
+		"9b2be514a04377113a6cdafe79dd7d5f"
38
+		"2ecc8b5e9661189b86a7b22239907c25"
39
+		"2928313a65343a36ad4b1d292929"));
40
 
41
   rsa_public_key_clear(&pub);
42
   rsa_private_key_clear(&priv);