Rev 42 | Rev 51 | Go to most recent revision | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 42 | Rev 47 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | include /usr/share/dpatch/dpatch.make |
8 | include /usr/share/dpatch/dpatch.make |
9 | 9 | ||
10 | # These are used for cross-compiling and for saving the configure script |
10 | # These are used for cross-compiling and for saving the configure script |
11 | # from having to guess our platform (since we know it already) |
11 | # from having to guess our platform (since we know it already) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
- | 17 | LDFLAGS = -Wl,--as-needed |
|
17 | 18 | ||
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | CFLAGS += -O0 |
20 | CFLAGS += -O0 |
20 | else |
21 | else |
21 | CFLAGS += -O2 |
22 | CFLAGS += -O2 |
22 | endif |
23 | endif |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | INSTALL_PROGRAM += -s |
25 | INSTALL_PROGRAM += -s |
25 | endif |
26 | endif |
26 | 27 | ||
27 | config.status: ${DPATCH_STAMPFN} configure |
28 | config.status: ${DPATCH_STAMPFN} configure |
28 | dh_testdir |
29 | dh_testdir |
29 | # Add here commands to configure the package. |
30 | # Add here commands to configure the package. |
30 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --build=$(DEB_BUILD_GNU_TYPE) \ |
32 | --prefix=/usr \ |
33 | --prefix=/usr \ |
33 | --mandir=\$${prefix}/share/man \ |
34 | --mandir=\$${prefix}/share/man \ |
34 | --infodir=\$${prefix}/share/info \ |
35 | --infodir=\$${prefix}/share/info \ |
35 | --enable-shared \ |
36 | --enable-shared \ |
36 | --disable-dependency-tracking |
37 | --disable-dependency-tracking \ |
- | 38 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" |
|
37 | 39 | ||
38 | 40 | ||
39 | build: build-stamp |
41 | build: build-stamp |
40 | build-stamp: config.status |
42 | build-stamp: config.status |
41 | dh_testdir |
43 | dh_testdir |
42 | 44 | ||
43 | # Add here commands to compile the package. |
45 | # Add here commands to compile the package. |
44 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
46 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
45 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
47 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
46 | $(MAKE) check |
48 | $(MAKE) check |
47 | endif |
49 | endif |
48 | 50 | ||
49 | touch build-stamp |
51 | touch build-stamp |
50 | 52 | ||
51 | clean: clean-patched unpatch |
53 | clean: clean-patched unpatch |
52 | dh_clean |
54 | dh_clean |
53 | 55 | ||
54 | clean-patched: |
56 | clean-patched: |
55 | dh_testdir |
57 | dh_testdir |
56 | dh_testroot |
58 | dh_testroot |
57 | rm -f build-stamp |
59 | rm -f build-stamp |
58 | 60 | ||
59 | # Add here commands to clean up after the build process. |
61 | # Add here commands to clean up after the build process. |
60 | [ ! -f Makefile ] || $(MAKE) distclean |
62 | [ ! -f Makefile ] || $(MAKE) distclean |
61 | 63 | ||
62 | install: build |
64 | install: build |
63 | dh_testdir |
65 | dh_testdir |
64 | dh_testroot |
66 | dh_testroot |
65 | dh_clean -k |
67 | dh_clean -k |
66 | dh_installdirs |
68 | dh_installdirs |
67 | 69 | ||
68 | # Add here commands to install the package into debian/tmp |
70 | # Add here commands to install the package into debian/tmp |
69 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
71 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
70 | 72 | ||
71 | # Build architecture-independent files here. |
73 | # Build architecture-independent files here. |
72 | binary-indep: build install |
74 | binary-indep: build install |
- | 75 | dh_testdir |
|
- | 76 | dh_testroot |
|
73 | # We have nothing to do by default. |
77 | dh_installchangelogs -i ChangeLog |
- | 78 | dh_installdocs -i |
|
- | 79 | dh_compress -i |
|
- | 80 | dh_fixperms -i |
|
- | 81 | dh_installdeb -i |
|
- | 82 | dh_shlibdeps -i |
|
- | 83 | dh_gencontrol -i |
|
- | 84 | dh_md5sums -i |
|
- | 85 | dh_builddeb -i |
|
74 | 86 | ||
75 | # Build architecture-dependent files here. |
87 | # Build architecture-dependent files here. |
76 | binary-arch: build install |
88 | binary-arch: build install |
77 | dh_testdir |
89 | dh_testdir |
78 | dh_testroot |
90 | dh_testroot |
79 | dh_install --sourcedir=debian/tmp |
91 | dh_install -a --sourcedir=debian/tmp |
- | 92 | dh_link -a |
|
80 | dh_installchangelogs ChangeLog |
93 | dh_installchangelogs -a ChangeLog |
81 | dh_installdocs |
94 | dh_installdocs -a |
82 | dh_installexamples |
95 | dh_installexamples -a |
83 | dh_installinfo |
96 | dh_installinfo -a |
84 | dh_installman |
97 | dh_installman -a |
85 | dh_link |
- | |
86 | dh_strip |
98 | dh_strip -a |
87 | dh_compress -X.pdf |
99 | dh_compress -X.pdf |
88 | dh_fixperms |
100 | dh_fixperms -a |
89 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
101 | dh_makeshlibs #-V 'libnettle2 (>= 1.15)' |
90 | dh_installdeb |
102 | dh_installdeb -a |
91 | dh_shlibdeps |
103 | dh_shlibdeps -a |
92 | dh_gencontrol |
104 | dh_gencontrol -a |
93 | dh_md5sums |
105 | dh_md5sums -a |
94 | dh_builddeb |
106 | dh_builddeb -a |
95 | 107 | ||
96 | binary: binary-indep binary-arch |
108 | binary: binary-indep binary-arch |
97 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |
109 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |