Rev 3 | Rev 6 | Go to most recent revision | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 4 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | include /usr/share/dpatch/dpatch.make |
8 | include /usr/share/dpatch/dpatch.make |
9 | 9 | ||
10 | # These are used for cross-compiling and for saving the configure script |
10 | # These are used for cross-compiling and for saving the configure script |
11 | # from having to guess our platform (since we know it already) |
11 | # from having to guess our platform (since we know it already) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
17 | 17 | ||
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
18 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | CFLAGS += -O0 |
19 | CFLAGS += -O0 |
20 | else |
20 | else |
21 | CFLAGS += -O2 |
21 | CFLAGS += -O2 |
22 | endif |
22 | endif |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
23 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
24 | INSTALL_PROGRAM += -s |
24 | INSTALL_PROGRAM += -s |
25 | endif |
25 | endif |
26 | 26 | ||
27 | # shared library versions, option 1 |
27 | # shared library versions, option 1 |
28 | version=2.0.5 |
28 | version=2.0.5 |
29 | major=2 |
29 | major=2 |
30 | # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so |
30 | # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so |
31 | #version=`ls src/.libs/lib*.so.* | \ |
31 | #version=`ls src/.libs/lib*.so.* | \ |
32 | # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'` |
32 | # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'` |
33 | #major=`ls src/.libs/lib*.so.* | \ |
33 | #major=`ls src/.libs/lib*.so.* | \ |
34 | # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'` |
34 | # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'` |
35 | 35 | ||
- | 36 | configure: config.status |
|
36 | config.status: patch configure |
37 | config.status: ${DPATCH_STAMPFN} |
37 | dh_testdir |
38 | dh_testdir |
38 | # Add here commands to configure the package. |
39 | # Add here commands to configure the package. |
39 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
40 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
40 | --build=$(DEB_BUILD_GNU_TYPE) \ |
41 | --build=$(DEB_BUILD_GNU_TYPE) \ |
41 | --prefix=/usr \ |
42 | --prefix=/usr \ |
42 | --mandir=\$${prefix}/share/man \ |
43 | --mandir=\$${prefix}/share/man \ |
43 | --infodir=\$${prefix}/share/info \ |
44 | --infodir=\$${prefix}/share/info \ |
44 | --enable-shared \ |
45 | --enable-shared \ |
45 | --disable-dependency-tracking |
46 | --disable-dependency-tracking |
46 | 47 | ||
47 | 48 | ||
48 | build: build-stamp |
49 | build: build-stamp |
49 | build-stamp: config.status |
50 | build-stamp: config.status |
50 | dh_testdir |
51 | dh_testdir |
51 | 52 | ||
52 | # Add here commands to compile the package. |
53 | # Add here commands to compile the package. |
53 | $(MAKE) |
54 | $(MAKE) |
54 | 55 | ||
55 | touch build-stamp |
56 | touch build-stamp |
56 | 57 | ||
57 | clean: clean-patched unpatch |
58 | clean: clean-patched unpatch |
- | 59 | dh_clean |
|
- | 60 | ||
58 | clean-patched: |
61 | clean-patched: |
59 | dh_testdir |
62 | dh_testdir |
60 | dh_testroot |
63 | dh_testroot |
61 | rm -f build-stamp |
64 | rm -f build-stamp |
62 | 65 | ||
63 | # Add here commands to clean up after the build process. |
66 | # Add here commands to clean up after the build process. |
64 | -$(MAKE) distclean |
67 | -$(MAKE) distclean |
65 | 68 | ||
66 | dh_clean |
- | |
67 | - | ||
68 | install: build |
69 | install: build |
69 | dh_testdir |
70 | dh_testdir |
70 | dh_testroot |
71 | dh_testroot |
71 | dh_clean -k |
72 | dh_clean -k |
72 | dh_installdirs |
73 | dh_installdirs |
73 | 74 | ||
74 | # Add here commands to install the package into debian/tmp |
75 | # Add here commands to install the package into debian/tmp |
75 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
76 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
76 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
77 | mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle |
77 | 78 | ||
78 | # Build architecture-independent files here. |
79 | # Build architecture-independent files here. |
79 | binary-indep: build install |
80 | binary-indep: build install |
80 | # We have nothing to do by default. |
81 | # We have nothing to do by default. |
81 | 82 | ||
82 | # Build architecture-dependent files here. |
83 | # Build architecture-dependent files here. |
83 | binary-arch: build install |
84 | binary-arch: build install |
84 | dh_testdir |
85 | dh_testdir |
85 | dh_testroot |
86 | dh_testroot |
86 | dh_movefiles |
87 | dh_movefiles |
87 | dh_installchangelogs ChangeLog |
88 | dh_installchangelogs ChangeLog |
88 | dh_installdocs |
89 | dh_installdocs |
89 | dh_installexamples |
90 | dh_installexamples |
90 | dh_installinfo |
91 | dh_installinfo |
91 | dh_installman |
92 | dh_installman |
92 | dh_link |
93 | dh_link |
93 | dh_strip |
94 | dh_strip |
94 | dh_compress |
95 | dh_compress |
95 | dh_fixperms |
96 | dh_fixperms |
96 | dh_makeshlibs |
97 | dh_makeshlibs |
97 | dh_installdeb |
98 | dh_installdeb |
98 | dh_shlibdeps |
99 | dh_shlibdeps |
99 | dh_gencontrol |
100 | dh_gencontrol |
100 | dh_md5sums |
101 | dh_md5sums |
101 | dh_builddeb |
102 | dh_builddeb |
102 | 103 | ||
103 | binary: binary-indep binary-arch |
104 | binary: binary-indep binary-arch |
104 | .PHONY: build clean binary-indep binary-arch binary install |
105 | .PHONY: configure build clean clean-patched binary-indep binary-arch binary install |