Rev 189 | Rev 192 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 189 | Rev 190 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | 8 | ||
9 | # These are used for cross-compiling and for saving the configure script |
9 | # These are used for cross-compiling and for saving the configure script |
10 | # from having to guess our platform (since we know it already) |
10 | # from having to guess our platform (since we know it already) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH) |
13 | DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH) |
14 | 14 | ||
15 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
16 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
16 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
17 | else |
17 | else |
18 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
18 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
19 | endif |
19 | endif |
20 | 20 | ||
21 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
21 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
22 | ifneq (,$(parallel)) |
22 | ifneq (,$(parallel)) |
23 | jobsflag = -j$(parallel) |
23 | jobsflag = -j$(parallel) |
24 | endif |
24 | endif |
25 | 25 | ||
26 | config.status: configure |
26 | config.status: configure |
27 | dh_testdir |
27 | dh_testdir |
28 | # Add here commands to configure the package. |
28 | # Add here commands to configure the package. |
29 | dh_update_autotools_config |
29 | dh_update_autotools_config |
30 | ./configure $(buildflags) \ |
30 | ./configure $(buildflags) \ |
31 | --prefix=/usr \ |
31 | --prefix=/usr \ |
32 | --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \ |
32 | --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \ |
33 | --enable-shared \ |
33 | --enable-shared \ |
34 | --disable-dependency-tracking \ |
34 | --disable-dependency-tracking \ |
35 | $(shell DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed dpkg-buildflags --export=configure) |
35 | $(shell DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed dpkg-buildflags --export=configure) |
36 | 36 | ||
37 | 37 | ||
38 | build: build-stamp |
38 | build: build-stamp |
39 | build-stamp: config.status |
39 | build-stamp: config.status |
40 | dh_testdir |
40 | dh_testdir |
41 | 41 | ||
42 | # Add here commands to compile the package. |
42 | # Add here commands to compile the package. |
43 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
43 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
44 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
44 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
45 | $(MAKE) check |
45 | $(MAKE) check |
46 | endif |
46 | endif |
47 | 47 | ||
48 | touch build-stamp |
48 | touch build-stamp |
49 | 49 | ||
50 | clean: |
50 | clean: |
51 | dh_testdir |
51 | dh_testdir |
52 | dh_testroot |
52 | dh_testroot |
53 | rm -f build-stamp |
53 | rm -f build-stamp |
54 | 54 | ||
55 | # Add here commands to clean up after the build process. |
55 | # Add here commands to clean up after the build process. |
56 | [ ! -f Makefile ] || $(MAKE) distclean |
56 | [ ! -f Makefile ] || $(MAKE) distclean |
57 | dh_clean |
57 | dh_clean |
58 | 58 | ||
59 | install: build |
59 | install: build |
60 | dh_testdir |
60 | dh_testdir |
61 | dh_testroot |
61 | dh_testroot |
62 | dh_prep |
62 | dh_prep |
63 | dh_installdirs |
63 | dh_installdirs |
64 | 64 | ||
65 | # Add here commands to install the package into debian/tmp |
65 | # Add here commands to install the package into debian/tmp |
66 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
66 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
67 | 67 | ||
68 | # Build architecture-independent files here. |
68 | # Build architecture-independent files here. |
69 | build-indep: |
69 | build-indep: |
70 | binary-indep: |
70 | binary-indep: |
71 | # Nothing to do |
71 | # Nothing to do |
72 | 72 | ||
73 | # Build architecture-dependent files here. |
73 | # Build architecture-dependent files here. |
74 | build-arch: build |
74 | build-arch: build |
75 | binary-arch: build-arch install |
75 | binary-arch: build-arch install |
76 | dh_testdir |
76 | dh_testdir |
77 | dh_testroot |
77 | dh_testroot |
78 | dh_install -a --sourcedir=debian/tmp |
78 | dh_install -a --sourcedir=debian/tmp |
79 | dh_installdocs -a -Nnettle-bin |
79 | dh_installdocs -a -Nnettle-bin |
80 | dh_installdocs -pnettle-bin --link-doc=libnettle7 |
80 | dh_installdocs -pnettle-bin --link-doc=libnettle8 |
81 | dh_installchangelogs -a ChangeLog |
81 | dh_installchangelogs -a ChangeLog |
82 | dh_installexamples -a |
82 | dh_installexamples -a |
83 | dh_installinfo -a |
83 | dh_installinfo -a |
84 | dh_installman -a |
84 | dh_installman -a |
85 | dh_lintian -a |
85 | dh_lintian -a |
86 | dh_strip -a |
86 | dh_strip -a |
87 | dh_compress -a -X.pdf |
87 | dh_compress -a -X.pdf |
88 | dh_fixperms -a |
88 | dh_fixperms -a |
89 | dh_makeshlibs -a -V |
89 | dh_makeshlibs -a -V |
90 | dh_installdeb -a |
90 | dh_installdeb -a |
91 | dh_shlibdeps -a |
91 | dh_shlibdeps -a |
92 | dh_gencontrol -a |
92 | dh_gencontrol -a |
93 | dh_md5sums -a |
93 | dh_md5sums -a |
94 | dh_builddeb -a |
94 | dh_builddeb -a |
95 | 95 | ||
96 | binary: binary-arch |
96 | binary: binary-arch |
97 | .PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install |
97 | .PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install |