Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 190 | Rev 194 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
 
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
8
 
9
# These are used for cross-compiling and for saving the configure script
10
# from having to guess our platform (since we know it already)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
77 magnus 13
DEB_HOST_MULTIARCH  ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
2 magnus 14
 
65 magnus 15
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
16
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
2 magnus 17
else
65 magnus 18
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
2 magnus 19
endif
65 magnus 20
 
21
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
22
ifneq (,$(parallel))
23
jobsflag = -j$(parallel)
2 magnus 24
endif
25
 
64 magnus 26
config.status: configure
2 magnus 27
	dh_testdir
28
	# Add here commands to configure the package.
170 magnus 29
	dh_update_autotools_config
65 magnus 30
	./configure $(buildflags) \
47 magnus 31
		    --prefix=/usr \
77 magnus 32
		    --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
47 magnus 33
	            --enable-shared \
34
	            --disable-dependency-tracking \
192 magnus 35
	            $(shell dpkg-buildflags --export=configure)
2 magnus 36
 
37
build: build-stamp
38
build-stamp:  config.status
39
	dh_testdir
40
 
41
	# Add here commands to compile the package.
65 magnus 42
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
54 magnus 43
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
15 magnus 44
	$(MAKE) check
45
endif
2 magnus 46
 
47
	touch build-stamp
48
 
64 magnus 49
clean:
2 magnus 50
	dh_testdir
51
	dh_testroot
52
	rm -f build-stamp
53
 
54
	# Add here commands to clean up after the build process.
35 magnus 55
	[ ! -f Makefile ] || $(MAKE) distclean
64 magnus 56
	dh_clean
2 magnus 57
 
58
install: build
59
	dh_testdir
60
	dh_testroot
67 magnus 61
	dh_prep
2 magnus 62
	dh_installdirs
63
 
64
	# Add here commands to install the package into debian/tmp
65
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
66
 
67
# Build architecture-independent files here.
67 magnus 68
build-indep:
52 magnus 69
binary-indep:
70
# Nothing to do
2 magnus 71
 
72
# Build architecture-dependent files here.
67 magnus 73
build-arch: build
74
binary-arch: build-arch install
2 magnus 75
	dh_testdir
76
	dh_testroot
47 magnus 77
	dh_install -a --sourcedir=debian/tmp
189 magnus 78
	dh_installdocs -a -Nnettle-bin
190 magnus 79
	dh_installdocs -pnettle-bin --link-doc=libnettle8
47 magnus 80
	dh_installchangelogs -a ChangeLog
81
	dh_installexamples -a
82
	dh_installinfo -a
83
	dh_installman -a
185 magnus 84
	dh_lintian -a
165 magnus 85
	dh_strip -a
52 magnus 86
	dh_compress -a -X.pdf
47 magnus 87
	dh_fixperms -a
73 magnus 88
	dh_makeshlibs -a -V
47 magnus 89
	dh_installdeb -a
90
	dh_shlibdeps -a
91
	dh_gencontrol -a
92
	dh_md5sums -a
93
	dh_builddeb -a
2 magnus 94
 
52 magnus 95
binary: binary-arch
67 magnus 96
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install