Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 15 | Rev 42 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
 
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
3 magnus 8
include /usr/share/dpatch/dpatch.make
2 magnus 9
 
10
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
 
15
 
16
CFLAGS = -Wall -g
17
 
18
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19
	CFLAGS += -O0
20
else
21
	CFLAGS += -O2
22
endif
23
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
24
	INSTALL_PROGRAM += -s
25
endif
26
 
6 magnus 27
config.status: ${DPATCH_STAMPFN} configure
2 magnus 28
	dh_testdir
29
	# Add here commands to configure the package.
30
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
31
	                               --build=$(DEB_BUILD_GNU_TYPE) \
32
			                           --prefix=/usr \
33
	                               --mandir=\$${prefix}/share/man \
34
	                               --infodir=\$${prefix}/share/info \
35
	                               --enable-shared \
36
	                               --disable-dependency-tracking
37
 
38
 
39
build: build-stamp
40
build-stamp:  config.status
41
	dh_testdir
42
 
43
	# Add here commands to compile the package.
15 magnus 44
	$(MAKE) MAKEINFO='makeinfo --enable-encoding'
45
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
46
	$(MAKE) check
47
endif
2 magnus 48
 
49
	touch build-stamp
50
 
3 magnus 51
clean: clean-patched unpatch
4 magnus 52
	dh_clean
53
 
3 magnus 54
clean-patched:
2 magnus 55
	dh_testdir
56
	dh_testroot
57
	rm -f build-stamp
58
 
59
	# Add here commands to clean up after the build process.
35 magnus 60
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 61
 
62
install: build
63
	dh_testdir
64
	dh_testroot
65
	dh_clean -k
66
	dh_installdirs
67
 
68
	# Add here commands to install the package into debian/tmp
69
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
70
	mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle
71
 
72
# Build architecture-independent files here.
73
binary-indep: build install
74
# We have nothing to do by default.
75
 
76
# Build architecture-dependent files here.
77
binary-arch: build install
78
	dh_testdir
79
	dh_testroot
15 magnus 80
	dh_install --sourcedir=debian/tmp
2 magnus 81
	dh_installchangelogs ChangeLog
82
	dh_installdocs
83
	dh_installexamples
84
	dh_installinfo
85
	dh_installman
86
	dh_link
87
	dh_strip
15 magnus 88
	dh_compress -X.pdf
2 magnus 89
	dh_fixperms
9 magnus 90
	dh_makeshlibs -V 'libnettle2 (>= 1.15)'
2 magnus 91
	dh_installdeb
9 magnus 92
	dh_shlibdeps
2 magnus 93
	dh_gencontrol
94
	dh_md5sums
95
	dh_builddeb
96
 
97
binary: binary-indep binary-arch
6 magnus 98
.PHONY: build clean clean-patched binary-indep binary-arch binary install