Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 4 | Rev 8 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
 
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
3 magnus 8
include /usr/share/dpatch/dpatch.make
2 magnus 9
 
10
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
 
15
 
16
CFLAGS = -Wall -g
17
 
18
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19
	CFLAGS += -O0
20
else
21
	CFLAGS += -O2
22
endif
23
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
24
	INSTALL_PROGRAM += -s
25
endif
26
 
27
# shared library versions, option 1
28
version=2.0.5
29
major=2
30
# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
31
#version=`ls src/.libs/lib*.so.* | \
32
# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
33
#major=`ls src/.libs/lib*.so.* | \
34
# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
35
 
6 magnus 36
config.status: ${DPATCH_STAMPFN} configure
2 magnus 37
	dh_testdir
38
	# Add here commands to configure the package.
39
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
40
	                               --build=$(DEB_BUILD_GNU_TYPE) \
41
			                           --prefix=/usr \
42
	                               --mandir=\$${prefix}/share/man \
43
	                               --infodir=\$${prefix}/share/info \
44
	                               --enable-shared \
45
	                               --disable-dependency-tracking
46
 
47
 
48
build: build-stamp
49
build-stamp:  config.status
50
	dh_testdir
51
 
52
	# Add here commands to compile the package.
53
	$(MAKE)
54
 
55
	touch build-stamp
56
 
3 magnus 57
clean: clean-patched unpatch
4 magnus 58
	dh_clean
59
 
3 magnus 60
clean-patched:
2 magnus 61
	dh_testdir
62
	dh_testroot
63
	rm -f build-stamp
64
 
65
	# Add here commands to clean up after the build process.
66
	-$(MAKE) distclean
67
 
68
install: build
69
	dh_testdir
70
	dh_testroot
71
	dh_clean -k
72
	dh_installdirs
73
 
74
	# Add here commands to install the package into debian/tmp
75
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
76
	mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle
77
 
78
# Build architecture-independent files here.
79
binary-indep: build install
80
# We have nothing to do by default.
81
 
82
# Build architecture-dependent files here.
83
binary-arch: build install
84
	dh_testdir
85
	dh_testroot
86
	dh_movefiles
87
	dh_installchangelogs ChangeLog
88
	dh_installdocs
89
	dh_installexamples
90
	dh_installinfo
91
	dh_installman
92
	dh_link
93
	dh_strip
94
	dh_compress
95
	dh_fixperms
96
	dh_makeshlibs
97
	dh_installdeb
98
	dh_shlibdeps
99
	dh_gencontrol
100
	dh_md5sums
101
	dh_builddeb
102
 
103
binary: binary-indep binary-arch
6 magnus 104
.PHONY: build clean clean-patched binary-indep binary-arch binary install