Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 53 | Rev 65 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
 
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
3 magnus 8
include /usr/share/dpatch/dpatch.make
2 magnus 9
 
10
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
 
15
 
16
CFLAGS = -Wall -g
47 magnus 17
LDFLAGS = -Wl,--as-needed
2 magnus 18
 
54 magnus 19
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
2 magnus 20
	CFLAGS += -O0
21
else
22
	CFLAGS += -O2
23
endif
53 magnus 24
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
2 magnus 25
	INSTALL_PROGRAM += -s
26
endif
27
 
6 magnus 28
config.status: ${DPATCH_STAMPFN} configure
2 magnus 29
	dh_testdir
30
	# Add here commands to configure the package.
47 magnus 31
	./configure --host=$(DEB_HOST_GNU_TYPE) \
32
		    --build=$(DEB_BUILD_GNU_TYPE) \
33
		    --prefix=/usr \
34
	            --mandir=\$${prefix}/share/man \
35
	            --infodir=\$${prefix}/share/info \
36
	            --enable-shared \
37
	            --disable-dependency-tracking \
38
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
2 magnus 39
 
40
 
41
build: build-stamp
42
build-stamp:  config.status
43
	dh_testdir
44
 
45
	# Add here commands to compile the package.
15 magnus 46
	$(MAKE) MAKEINFO='makeinfo --enable-encoding'
54 magnus 47
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
15 magnus 48
	$(MAKE) check
49
endif
2 magnus 50
 
51
	touch build-stamp
52
 
3 magnus 53
clean: clean-patched unpatch
4 magnus 54
	dh_clean
55
 
3 magnus 56
clean-patched:
2 magnus 57
	dh_testdir
58
	dh_testroot
59
	rm -f build-stamp
60
 
61
	# Add here commands to clean up after the build process.
35 magnus 62
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 63
 
64
install: build
65
	dh_testdir
66
	dh_testroot
67
	dh_clean -k
68
	dh_installdirs
69
 
70
	# Add here commands to install the package into debian/tmp
71
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
72
 
73
# Build architecture-independent files here.
52 magnus 74
binary-indep:
75
# Nothing to do
2 magnus 76
 
77
# Build architecture-dependent files here.
78
binary-arch: build install
79
	dh_testdir
80
	dh_testroot
47 magnus 81
	dh_install -a --sourcedir=debian/tmp
82
	dh_link -a
83
	dh_installchangelogs -a ChangeLog
84
	dh_installdocs -a
85
	dh_installexamples -a
86
	dh_installinfo -a
87
	dh_installman -a
51 magnus 88
	dh_strip -a --dbg-package=nettle-dbg
52 magnus 89
	dh_compress -a -X.pdf
47 magnus 90
	dh_fixperms -a
91
	dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
92
	dh_installdeb -a
93
	dh_shlibdeps -a
94
	dh_gencontrol -a
95
	dh_md5sums -a
96
	dh_builddeb -a
2 magnus 97
 
52 magnus 98
binary: binary-arch
6 magnus 99
.PHONY: build clean clean-patched binary-indep binary-arch binary install