Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 8 | Rev 15 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
 
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
3 magnus 8
include /usr/share/dpatch/dpatch.make
2 magnus 9
 
10
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
 
15
 
16
CFLAGS = -Wall -g
17
 
18
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19
	CFLAGS += -O0
20
else
21
	CFLAGS += -O2
22
endif
23
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
24
	INSTALL_PROGRAM += -s
25
endif
26
 
6 magnus 27
config.status: ${DPATCH_STAMPFN} configure
2 magnus 28
	dh_testdir
29
	# Add here commands to configure the package.
30
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
31
	                               --build=$(DEB_BUILD_GNU_TYPE) \
32
			                           --prefix=/usr \
33
	                               --mandir=\$${prefix}/share/man \
34
	                               --infodir=\$${prefix}/share/info \
35
	                               --enable-shared \
36
	                               --disable-dependency-tracking
37
 
38
 
39
build: build-stamp
40
build-stamp:  config.status
41
	dh_testdir
42
 
43
	# Add here commands to compile the package.
44
	$(MAKE)
45
 
46
	touch build-stamp
47
 
3 magnus 48
clean: clean-patched unpatch
4 magnus 49
	dh_clean
50
 
3 magnus 51
clean-patched:
2 magnus 52
	dh_testdir
53
	dh_testroot
54
	rm -f build-stamp
55
 
56
	# Add here commands to clean up after the build process.
57
	-$(MAKE) distclean
58
 
59
install: build
60
	dh_testdir
61
	dh_testroot
62
	dh_clean -k
63
	dh_installdirs
64
 
65
	# Add here commands to install the package into debian/tmp
66
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
67
	mv $(CURDIR)/debian/tmp/usr/bin/sexp-conv $(CURDIR)/debian/tmp/usr/bin/sexp-conv.nettle
68
 
69
# Build architecture-independent files here.
70
binary-indep: build install
71
# We have nothing to do by default.
72
 
73
# Build architecture-dependent files here.
74
binary-arch: build install
75
	dh_testdir
76
	dh_testroot
77
	dh_movefiles
78
	dh_installchangelogs ChangeLog
79
	dh_installdocs
80
	dh_installexamples
81
	dh_installinfo
82
	dh_installman
83
	dh_link
84
	dh_strip
85
	dh_compress
86
	dh_fixperms
9 magnus 87
	dh_makeshlibs -V 'libnettle2 (>= 1.15)'
2 magnus 88
	dh_installdeb
9 magnus 89
	dh_shlibdeps
2 magnus 90
	dh_gencontrol
91
	dh_md5sums
92
	dh_builddeb
93
 
94
binary: binary-indep binary-arch
6 magnus 95
.PHONY: build clean clean-patched binary-indep binary-arch binary install