Rev 51 | Rev 53 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 51 | Rev 52 | ||
---|---|---|---|
Line 69... | Line 69... | ||
69 | 69 | ||
70 | # Add here commands to install the package into debian/tmp |
70 | # Add here commands to install the package into debian/tmp |
71 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
71 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
72 | 72 | ||
73 | # Build architecture-independent files here. |
73 | # Build architecture-independent files here. |
74 | binary-indep: build install |
74 | binary-indep: |
75 | dh_testdir |
- | |
76 | dh_testroot |
- | |
77 | dh_installchangelogs -i ChangeLog |
- | |
78 | dh_installdocs -i |
- | |
79 | dh_compress -i |
- | |
80 | dh_fixperms -i |
- | |
81 | dh_installdeb -i |
- | |
82 | dh_shlibdeps -i |
75 | # Nothing to do |
83 | dh_gencontrol -i |
- | |
84 | dh_md5sums -i |
- | |
85 | dh_builddeb -i |
- | |
86 | 76 | ||
87 | # Build architecture-dependent files here. |
77 | # Build architecture-dependent files here. |
88 | binary-arch: build install |
78 | binary-arch: build install |
89 | dh_testdir |
79 | dh_testdir |
90 | dh_testroot |
80 | dh_testroot |
Line 94... | Line 84... | ||
94 | dh_installdocs -a |
84 | dh_installdocs -a |
95 | dh_installexamples -a |
85 | dh_installexamples -a |
96 | dh_installinfo -a |
86 | dh_installinfo -a |
97 | dh_installman -a |
87 | dh_installman -a |
98 | dh_strip -a --dbg-package=nettle-dbg |
88 | dh_strip -a --dbg-package=nettle-dbg |
99 | dh_compress -X.pdf |
89 | dh_compress -a -X.pdf |
100 | dh_fixperms -a |
90 | dh_fixperms -a |
101 | dh_makeshlibs #-V 'libnettle2 (>= 1.15)' |
91 | dh_makeshlibs #-V 'libnettle2 (>= 1.15)' |
102 | dh_installdeb -a |
92 | dh_installdeb -a |
103 | dh_shlibdeps -a |
93 | dh_shlibdeps -a |
104 | dh_gencontrol -a |
94 | dh_gencontrol -a |
105 | dh_md5sums -a |
95 | dh_md5sums -a |
106 | dh_builddeb -a |
96 | dh_builddeb -a |
107 | 97 | ||
108 | binary: binary-indep binary-arch |
98 | binary: binary-arch |
109 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |
99 | .PHONY: build clean clean-patched binary-indep binary-arch binary install |