Rev 64 | Rev 67 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 64 | Rev 65 | ||
---|---|---|---|
Line 9... | Line 9... | ||
9 | # These are used for cross-compiling and for saving the configure script |
9 | # These are used for cross-compiling and for saving the configure script |
10 | # from having to guess our platform (since we know it already) |
10 | # from having to guess our platform (since we know it already) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | 13 | ||
14 | CFLAGS = -Wall -g |
- | |
15 | LDFLAGS = -Wl,--as-needed |
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
16 | - | ||
17 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
18 | CFLAGS += -O0 |
- | |
19 | else |
16 | else |
20 | CFLAGS += -O2 |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
21 | endif |
18 | endif |
- | 19 | ||
22 | ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS))) |
20 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
23 | INSTALL_PROGRAM += -s |
21 | ifneq (,$(parallel)) |
- | 22 | jobsflag = -j$(parallel) |
|
24 | endif |
23 | endif |
25 | 24 | ||
26 | config.status: configure |
25 | config.status: configure |
27 | dh_testdir |
26 | dh_testdir |
28 | # Add here commands to configure the package. |
27 | # Add here commands to configure the package. |
29 | dh_autotools-dev_updateconfig |
28 | dh_autotools-dev_updateconfig |
30 | ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
29 | ./configure $(buildflags) \ |
31 | --build=$(DEB_BUILD_GNU_TYPE) \ |
- | |
32 | --prefix=/usr \ |
30 | --prefix=/usr \ |
33 | --mandir=\$${prefix}/share/man \ |
31 | --libdir=/usr/lib \ |
34 | --infodir=\$${prefix}/share/info \ |
- | |
35 | --enable-shared \ |
32 | --enable-shared \ |
36 | --disable-dependency-tracking \ |
33 | --disable-dependency-tracking \ |
37 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" |
34 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed" |
38 | 35 | ||
39 | 36 | ||
40 | build: build-stamp |
37 | build: build-stamp |
41 | build-stamp: config.status |
38 | build-stamp: config.status |
42 | dh_testdir |
39 | dh_testdir |
43 | 40 | ||
44 | # Add here commands to compile the package. |
41 | # Add here commands to compile the package. |
45 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
42 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
46 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
43 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
47 | $(MAKE) check |
44 | $(MAKE) check |
48 | endif |
45 | endif |
49 | 46 | ||
50 | touch build-stamp |
47 | touch build-stamp |
Line 84... | Line 81... | ||
84 | dh_installinfo -a |
81 | dh_installinfo -a |
85 | dh_installman -a |
82 | dh_installman -a |
86 | dh_strip -a --dbg-package=nettle-dbg |
83 | dh_strip -a --dbg-package=nettle-dbg |
87 | dh_compress -a -X.pdf |
84 | dh_compress -a -X.pdf |
88 | dh_fixperms -a |
85 | dh_fixperms -a |
89 | dh_makeshlibs #-V 'libnettle2 (>= 1.15)' |
86 | dh_makeshlibs -a |
90 | dh_installdeb -a |
87 | dh_installdeb -a |
91 | dh_shlibdeps -a |
88 | dh_shlibdeps -a |
92 | dh_gencontrol -a |
89 | dh_gencontrol -a |
93 | dh_md5sums -a |
90 | dh_md5sums -a |
94 | dh_builddeb -a |
91 | dh_builddeb -a |