Rev 73 | Rev 95 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 73 | Rev 77 | ||
---|---|---|---|
Line 8... | Line 8... | ||
8 | 8 | ||
9 | # These are used for cross-compiling and for saving the configure script |
9 | # These are used for cross-compiling and for saving the configure script |
10 | # from having to guess our platform (since we know it already) |
10 | # from having to guess our platform (since we know it already) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
- | 13 | DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH) |
|
13 | 14 | ||
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
16 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
16 | else |
17 | else |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
18 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
Line 26... | Line 27... | ||
26 | dh_testdir |
27 | dh_testdir |
27 | # Add here commands to configure the package. |
28 | # Add here commands to configure the package. |
28 | dh_autotools-dev_updateconfig |
29 | dh_autotools-dev_updateconfig |
29 | ./configure $(buildflags) \ |
30 | ./configure $(buildflags) \ |
30 | --prefix=/usr \ |
31 | --prefix=/usr \ |
31 | --libdir=\$${prefix}/lib \ |
32 | --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \ |
32 | --enable-shared \ |
33 | --enable-shared \ |
33 | --disable-dependency-tracking \ |
34 | --disable-dependency-tracking \ |
34 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed" |
35 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed" |
35 | 36 | ||
36 | 37 |