Rev 53 | Rev 64 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 53 | Rev 54 | ||
---|---|---|---|
Line 14... | Line 14... | ||
14 | 14 | ||
15 | 15 | ||
16 | CFLAGS = -Wall -g |
16 | CFLAGS = -Wall -g |
17 | LDFLAGS = -Wl,--as-needed |
17 | LDFLAGS = -Wl,--as-needed |
18 | 18 | ||
19 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
19 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
20 | CFLAGS += -O0 |
20 | CFLAGS += -O0 |
21 | else |
21 | else |
22 | CFLAGS += -O2 |
22 | CFLAGS += -O2 |
23 | endif |
23 | endif |
24 | ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS))) |
24 | ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS))) |
Line 42... | Line 42... | ||
42 | build-stamp: config.status |
42 | build-stamp: config.status |
43 | dh_testdir |
43 | dh_testdir |
44 | 44 | ||
45 | # Add here commands to compile the package. |
45 | # Add here commands to compile the package. |
46 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
46 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
47 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
47 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
48 | $(MAKE) check |
48 | $(MAKE) check |
49 | endif |
49 | endif |
50 | 50 | ||
51 | touch build-stamp |
51 | touch build-stamp |
52 | 52 |