Rev 9 | Rev 35 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 9 | Rev 15 | ||
---|---|---|---|
Line 39... | Line 39... | ||
39 | build: build-stamp |
39 | build: build-stamp |
40 | build-stamp: config.status |
40 | build-stamp: config.status |
41 | dh_testdir |
41 | dh_testdir |
42 | 42 | ||
43 | # Add here commands to compile the package. |
43 | # Add here commands to compile the package. |
- | 44 | $(MAKE) MAKEINFO='makeinfo --enable-encoding' |
|
- | 45 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
|
44 | $(MAKE) |
46 | $(MAKE) check |
- | 47 | endif |
|
45 | 48 | ||
46 | touch build-stamp |
49 | touch build-stamp |
47 | 50 | ||
48 | clean: clean-patched unpatch |
51 | clean: clean-patched unpatch |
49 | dh_clean |
52 | dh_clean |
Line 72... | Line 75... | ||
72 | 75 | ||
73 | # Build architecture-dependent files here. |
76 | # Build architecture-dependent files here. |
74 | binary-arch: build install |
77 | binary-arch: build install |
75 | dh_testdir |
78 | dh_testdir |
76 | dh_testroot |
79 | dh_testroot |
77 | dh_movefiles |
80 | dh_install --sourcedir=debian/tmp |
78 | dh_installchangelogs ChangeLog |
81 | dh_installchangelogs ChangeLog |
79 | dh_installdocs |
82 | dh_installdocs |
80 | dh_installexamples |
83 | dh_installexamples |
81 | dh_installinfo |
84 | dh_installinfo |
82 | dh_installman |
85 | dh_installman |
83 | dh_link |
86 | dh_link |
84 | dh_strip |
87 | dh_strip |
85 | dh_compress |
88 | dh_compress -X.pdf |
86 | dh_fixperms |
89 | dh_fixperms |
87 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
90 | dh_makeshlibs -V 'libnettle2 (>= 1.15)' |
88 | dh_installdeb |
91 | dh_installdeb |
89 | dh_shlibdeps |
92 | dh_shlibdeps |
90 | dh_gencontrol |
93 | dh_gencontrol |