Rev 2 | Rev 4 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 2 | Rev 3 | ||
---|---|---|---|
Line 3... | Line 3... | ||
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | - | ||
- | 8 | include /usr/share/dpatch/dpatch.make |
|
9 | 9 | ||
10 | # These are used for cross-compiling and for saving the configure script |
10 | # These are used for cross-compiling and for saving the configure script |
11 | # from having to guess our platform (since we know it already) |
11 | # from having to guess our platform (since we know it already) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
Line 31... | Line 31... | ||
31 | #version=`ls src/.libs/lib*.so.* | \ |
31 | #version=`ls src/.libs/lib*.so.* | \ |
32 | # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'` |
32 | # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'` |
33 | #major=`ls src/.libs/lib*.so.* | \ |
33 | #major=`ls src/.libs/lib*.so.* | \ |
34 | # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'` |
34 | # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'` |
35 | 35 | ||
36 | config.status: configure |
36 | config.status: patch configure |
37 | dh_testdir |
37 | dh_testdir |
38 | ifneq "$(wildcard /usr/share/misc/config.sub)" "" |
- | |
39 | cp -f /usr/share/misc/config.sub config.sub |
- | |
40 | endif |
- | |
41 | ifneq "$(wildcard /usr/share/misc/config.guess)" "" |
- | |
42 | cp -f /usr/share/misc/config.guess config.guess |
- | |
43 | endif |
- | |
44 | # Add here commands to configure the package. |
38 | # Add here commands to configure the package. |
45 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
39 | CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
46 | --build=$(DEB_BUILD_GNU_TYPE) \ |
40 | --build=$(DEB_BUILD_GNU_TYPE) \ |
47 | --prefix=/usr \ |
41 | --prefix=/usr \ |
48 | --mandir=\$${prefix}/share/man \ |
42 | --mandir=\$${prefix}/share/man \ |
Line 58... | Line 52... | ||
58 | # Add here commands to compile the package. |
52 | # Add here commands to compile the package. |
59 | $(MAKE) |
53 | $(MAKE) |
60 | 54 | ||
61 | touch build-stamp |
55 | touch build-stamp |
62 | 56 | ||
- | 57 | clean: clean-patched unpatch |
|
63 | clean: |
58 | clean-patched: |
64 | dh_testdir |
59 | dh_testdir |
65 | dh_testroot |
60 | dh_testroot |
66 | rm -f build-stamp |
61 | rm -f build-stamp |
67 | 62 | ||
68 | # Add here commands to clean up after the build process. |
63 | # Add here commands to clean up after the build process. |
69 | -$(MAKE) distclean |
64 | -$(MAKE) distclean |
70 | ifneq "$(wildcard /usr/share/misc/config.sub)" "" |
- | |
71 | rm -f config.sub |
- | |
72 | endif |
- | |
73 | ifneq "$(wildcard /usr/share/misc/config.guess)" "" |
- | |
74 | rm -f config.guess |
- | |
75 | endif |
- | |
76 | -rm machine.m4 |
- | |
77 | -rm -r .lib |
- | |
78 | 65 | ||
79 | dh_clean |
66 | dh_clean |
80 | 67 | ||
81 | install: build |
68 | install: build |
82 | dh_testdir |
69 | dh_testdir |