Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 192 | Rev 195 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 192 Rev 194
Line 1... Line 1...
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
-
 
3
# Sample debian/rules that uses debhelper.
-
 
4
# GNU copyright 1997 to 1999 by Joey Hess.
-
 
5
2
6
# Uncomment this to turn on verbose mode.
-
 
-
 
3
%:
7
#export DH_VERBOSE=1
4
	dh $@
8
5
9
# These are used for cross-compiling and for saving the configure script
-
 
10
# from having to guess our platform (since we know it already)
-
 
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
13
DEB_HOST_MULTIARCH  ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH) 
-
 
14
-
 
15
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-
 
16
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
-
 
17
else
-
 
18
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
-
 
19
endif
-
 
20
-
 
21
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-
 
22
ifneq (,$(parallel))
-
 
23
jobsflag = -j$(parallel)
-
 
24
endif
-
 
25
-
 
26
config.status: configure
-
 
27
	dh_testdir
-
 
28
	# Add here commands to configure the package.
-
 
29
	dh_update_autotools_config
-
 
30
	./configure $(buildflags) \
-
 
31
		    --prefix=/usr \
-
 
32
		    --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
-
 
33
	            --enable-shared \
-
 
34
	            --disable-dependency-tracking \
-
 
35
	            $(shell dpkg-buildflags --export=configure)
-
 
36
-
 
37
build: build-stamp
-
 
38
build-stamp:  config.status
-
 
39
	dh_testdir
-
 
40
-
 
41
	# Add here commands to compile the package.
-
 
42
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
-
 
43
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-
 
44
	$(MAKE) check
-
 
45
endif
-
 
46
-
 
47
	touch build-stamp
-
 
48
-
 
49
clean:
-
 
50
	dh_testdir
-
 
51
	dh_testroot
-
 
52
	rm -f build-stamp 
-
 
53
-
 
54
	# Add here commands to clean up after the build process.
-
 
55
	[ ! -f Makefile ] || $(MAKE) distclean
-
 
56
	dh_clean
-
 
57
-
 
58
install: build
-
 
59
	dh_testdir
-
 
60
	dh_testroot
-
 
61
	dh_prep
-
 
62
	dh_installdirs
6
override_dh_installdocs:
63
-
 
64
	# Add here commands to install the package into debian/tmp
-
 
65
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-
 
66
-
 
67
# Build architecture-independent files here.
-
 
68
build-indep:
-
 
69
binary-indep:
-
 
70
# Nothing to do
-
 
71
-
 
72
# Build architecture-dependent files here.
-
 
73
build-arch: build
-
 
74
binary-arch: build-arch install
-
 
75
	dh_testdir
-
 
76
	dh_testroot
-
 
77
	dh_install -a --sourcedir=debian/tmp
-
 
78
	dh_installdocs -a -Nnettle-bin
7
	dh_installdocs -a -Nnettle-bin
79
	dh_installdocs -pnettle-bin --link-doc=libnettle8
8
	dh_installdocs -pnettle-bin --link-doc=libnettle8
80
	dh_installchangelogs -a ChangeLog
-
 
81
	dh_installexamples -a
-
 
82
	dh_installinfo -a
-
 
83
	dh_installman -a
-
 
84
	dh_lintian -a
-
 
85
	dh_strip -a
-
 
86
	dh_compress -a -X.pdf
-
 
87
	dh_fixperms -a
-
 
88
	dh_makeshlibs -a -V
-
 
89
	dh_installdeb -a
-
 
90
	dh_shlibdeps -a
-
 
91
	dh_gencontrol -a
-
 
92
	dh_md5sums -a
-
 
93
	dh_builddeb -a
-
 
94
9
95
binary: binary-arch
10
override_dh_auto_configure:
96
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install
11
	dh_auto_configure -- --enable-fat
-
 
12
-
 
13