Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 6 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 3 Rev 4
Line 31... Line 31...
31
#version=`ls src/.libs/lib*.so.* | \
31
#version=`ls src/.libs/lib*.so.* | \
32
# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
32
# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
33
#major=`ls src/.libs/lib*.so.* | \
33
#major=`ls src/.libs/lib*.so.* | \
34
# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
34
# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
35
35
-
 
36
configure: config.status
36
config.status: patch configure
37
config.status: ${DPATCH_STAMPFN}
37
	dh_testdir
38
	dh_testdir
38
	# Add here commands to configure the package.
39
	# Add here commands to configure the package.
39
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
40
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
40
	                               --build=$(DEB_BUILD_GNU_TYPE) \
41
	                               --build=$(DEB_BUILD_GNU_TYPE) \
41
			                           --prefix=/usr \
42
			                           --prefix=/usr \
Line 53... Line 54...
53
	$(MAKE)
54
	$(MAKE)
54
55
55
	touch build-stamp
56
	touch build-stamp
56
57
57
clean: clean-patched unpatch
58
clean: clean-patched unpatch
-
 
59
	dh_clean
-
 
60
58
clean-patched:
61
clean-patched:
59
	dh_testdir
62
	dh_testdir
60
	dh_testroot
63
	dh_testroot
61
	rm -f build-stamp 
64
	rm -f build-stamp 
62
65
63
	# Add here commands to clean up after the build process.
66
	# Add here commands to clean up after the build process.
64
	-$(MAKE) distclean
67
	-$(MAKE) distclean
65
68
66
	dh_clean 
-
 
67
-
 
68
install: build
69
install: build
69
	dh_testdir
70
	dh_testdir
70
	dh_testroot
71
	dh_testroot
71
	dh_clean -k 
72
	dh_clean -k 
72
	dh_installdirs
73
	dh_installdirs
Line 99... Line 100...
99
	dh_gencontrol
100
	dh_gencontrol
100
	dh_md5sums
101
	dh_md5sums
101
	dh_builddeb
102
	dh_builddeb
102
103
103
binary: binary-indep binary-arch
104
binary: binary-indep binary-arch
104
.PHONY: build clean binary-indep binary-arch binary install 
105
.PHONY: configure build clean clean-patched binary-indep binary-arch binary install