Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 42 | Rev 51 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 42 Rev 47
Line 12... Line 12...
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
14
15
15
16
CFLAGS = -Wall -g
16
CFLAGS = -Wall -g
-
 
17
LDFLAGS = -Wl,--as-needed
17
18
18
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19
	CFLAGS += -O0
20
	CFLAGS += -O0
20
else
21
else
21
	CFLAGS += -O2
22
	CFLAGS += -O2
Line 25... Line 26...
25
endif
26
endif
26
27
27
config.status: ${DPATCH_STAMPFN} configure
28
config.status: ${DPATCH_STAMPFN} configure
28
	dh_testdir
29
	dh_testdir
29
	# Add here commands to configure the package.
30
	# Add here commands to configure the package.
30
	CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
31
	./configure --host=$(DEB_HOST_GNU_TYPE) \
31
	                               --build=$(DEB_BUILD_GNU_TYPE) \
32
		    --build=$(DEB_BUILD_GNU_TYPE) \
32
			                           --prefix=/usr \
33
		    --prefix=/usr \
33
	                               --mandir=\$${prefix}/share/man \
34
	            --mandir=\$${prefix}/share/man \
34
	                               --infodir=\$${prefix}/share/info \
35
	            --infodir=\$${prefix}/share/info \
35
	                               --enable-shared \
36
	            --enable-shared \
36
	                               --disable-dependency-tracking
37
	            --disable-dependency-tracking \
-
 
38
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
37
39
38
40
39
build: build-stamp
41
build: build-stamp
40
build-stamp:  config.status
42
build-stamp:  config.status
41
	dh_testdir
43
	dh_testdir
Line 68... Line 70...
68
	# Add here commands to install the package into debian/tmp
70
	# Add here commands to install the package into debian/tmp
69
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
71
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
70
72
71
# Build architecture-independent files here.
73
# Build architecture-independent files here.
72
binary-indep: build install
74
binary-indep: build install
-
 
75
	dh_testdir
-
 
76
	dh_testroot
73
# We have nothing to do by default.
77
	dh_installchangelogs -i ChangeLog
-
 
78
	dh_installdocs -i
-
 
79
	dh_compress -i
-
 
80
	dh_fixperms -i
-
 
81
	dh_installdeb -i
-
 
82
	dh_shlibdeps -i
-
 
83
	dh_gencontrol -i
-
 
84
	dh_md5sums -i
-
 
85
	dh_builddeb -i
74
86
75
# Build architecture-dependent files here.
87
# Build architecture-dependent files here.
76
binary-arch: build install
88
binary-arch: build install
77
	dh_testdir
89
	dh_testdir
78
	dh_testroot
90
	dh_testroot
79
	dh_install --sourcedir=debian/tmp
91
	dh_install -a --sourcedir=debian/tmp
-
 
92
	dh_link -a
80
	dh_installchangelogs ChangeLog
93
	dh_installchangelogs -a ChangeLog
81
	dh_installdocs
94
	dh_installdocs -a
82
	dh_installexamples
95
	dh_installexamples -a
83
	dh_installinfo
96
	dh_installinfo -a
84
	dh_installman
97
	dh_installman -a
85
	dh_link
-
 
86
	dh_strip
98
	dh_strip -a
87
	dh_compress -X.pdf
99
	dh_compress -X.pdf
88
	dh_fixperms
100
	dh_fixperms -a
89
	dh_makeshlibs -V 'libnettle2 (>= 1.15)'
101
	dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
90
	dh_installdeb
102
	dh_installdeb -a
91
	dh_shlibdeps
103
	dh_shlibdeps -a
92
	dh_gencontrol
104
	dh_gencontrol -a
93
	dh_md5sums
105
	dh_md5sums -a
94
	dh_builddeb
106
	dh_builddeb -a
95
107
96
binary: binary-indep binary-arch
108
binary: binary-indep binary-arch
97
.PHONY: build clean clean-patched binary-indep binary-arch binary install
109
.PHONY: build clean clean-patched binary-indep binary-arch binary install