Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 54 | Rev 65 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 54 Rev 64
Line 3... Line 3...
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
5
6
# Uncomment this to turn on verbose mode.
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
7
#export DH_VERBOSE=1
8
include /usr/share/dpatch/dpatch.make
-
 
9
8
10
# These are used for cross-compiling and for saving the configure script
9
# These are used for cross-compiling and for saving the configure script
11
# from having to guess our platform (since we know it already)
10
# from having to guess our platform (since we know it already)
12
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14
13
15
-
 
16
CFLAGS = -Wall -g
14
CFLAGS = -Wall -g
17
LDFLAGS = -Wl,--as-needed
15
LDFLAGS = -Wl,--as-needed
18
16
19
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
17
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
20
	CFLAGS += -O0
18
	CFLAGS += -O0
Line 23... Line 21...
23
endif
21
endif
24
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
22
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
25
	INSTALL_PROGRAM += -s
23
	INSTALL_PROGRAM += -s
26
endif
24
endif
27
25
28
config.status: ${DPATCH_STAMPFN} configure
26
config.status: configure
29
	dh_testdir
27
	dh_testdir
30
	# Add here commands to configure the package.
28
	# Add here commands to configure the package.
-
 
29
	dh_autotools-dev_updateconfig
31
	./configure --host=$(DEB_HOST_GNU_TYPE) \
30
	./configure --host=$(DEB_HOST_GNU_TYPE) \
32
		    --build=$(DEB_BUILD_GNU_TYPE) \
31
		    --build=$(DEB_BUILD_GNU_TYPE) \
33
		    --prefix=/usr \
32
		    --prefix=/usr \
34
	            --mandir=\$${prefix}/share/man \
33
	            --mandir=\$${prefix}/share/man \
35
	            --infodir=\$${prefix}/share/info \
34
	            --infodir=\$${prefix}/share/info \
Line 48... Line 47...
48
	$(MAKE) check
47
	$(MAKE) check
49
endif
48
endif
50
49
51
	touch build-stamp
50
	touch build-stamp
52
51
53
clean: clean-patched unpatch
-
 
54
	dh_clean
52
clean:
55
-
 
56
clean-patched:
-
 
57
	dh_testdir
53
	dh_testdir
58
	dh_testroot
54
	dh_testroot
59
	rm -f build-stamp 
55
	rm -f build-stamp 
60
56
61
	# Add here commands to clean up after the build process.
57
	# Add here commands to clean up after the build process.
62
	[ ! -f Makefile ] || $(MAKE) distclean
58
	[ ! -f Makefile ] || $(MAKE) distclean
-
 
59
	dh_autotools-dev_restoreconfig
-
 
60
	dh_clean
63
61
64
install: build
62
install: build
65
	dh_testdir
63
	dh_testdir
66
	dh_testroot
64
	dh_testroot
67
	dh_clean -k 
65
	dh_clean -k