Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 65 | Rev 77 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 65 Rev 67
Line 26... Line 26...
26
	dh_testdir
26
	dh_testdir
27
	# Add here commands to configure the package.
27
	# Add here commands to configure the package.
28
	dh_autotools-dev_updateconfig
28
	dh_autotools-dev_updateconfig
29
	./configure $(buildflags) \
29
	./configure $(buildflags) \
30
		    --prefix=/usr \
30
		    --prefix=/usr \
31
		    --libdir=/usr/lib \
31
		    --libdir=\$${prefix}/lib \
32
	            --enable-shared \
32
	            --enable-shared \
33
	            --disable-dependency-tracking \
33
	            --disable-dependency-tracking \
34
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
34
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
35
35
36
36
Line 57... Line 57...
57
	dh_clean
57
	dh_clean
58
58
59
install: build
59
install: build
60
	dh_testdir
60
	dh_testdir
61
	dh_testroot
61
	dh_testroot
62
	dh_clean -k 
62
	dh_prep
63
	dh_installdirs
63
	dh_installdirs
64
64
65
	# Add here commands to install the package into debian/tmp
65
	# Add here commands to install the package into debian/tmp
66
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
66
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
67
67
68
# Build architecture-independent files here.
68
# Build architecture-independent files here.
-
 
69
build-indep:
69
binary-indep:
70
binary-indep:
70
# Nothing to do
71
# Nothing to do
71
72
72
# Build architecture-dependent files here.
73
# Build architecture-dependent files here.
-
 
74
build-arch: build
73
binary-arch: build install
75
binary-arch: build-arch install
74
	dh_testdir
76
	dh_testdir
75
	dh_testroot
77
	dh_testroot
76
	dh_install -a --sourcedir=debian/tmp
78
	dh_install -a --sourcedir=debian/tmp
77
	dh_link -a
79
	dh_link -a
78
	dh_installchangelogs -a ChangeLog
80
	dh_installchangelogs -a ChangeLog
Line 89... Line 91...
89
	dh_gencontrol -a
91
	dh_gencontrol -a
90
	dh_md5sums -a
92
	dh_md5sums -a
91
	dh_builddeb -a
93
	dh_builddeb -a
92
94
93
binary: binary-arch
95
binary: binary-arch
94
.PHONY: build clean clean-patched binary-indep binary-arch binary install
96
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install