Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 65 | Rev 77 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 65 Rev 67
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# GNU copyright 1997 to 1999 by Joey Hess.
4
# GNU copyright 1997 to 1999 by Joey Hess.
5
5
6
# Uncomment this to turn on verbose mode.
6
# Uncomment this to turn on verbose mode.
7
#export DH_VERBOSE=1
7
#export DH_VERBOSE=1
8
8
9
# These are used for cross-compiling and for saving the configure script
9
# These are used for cross-compiling and for saving the configure script
10
# from having to guess our platform (since we know it already)
10
# from having to guess our platform (since we know it already)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
13
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
16
else
16
else
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
18
endif
18
endif
19
19
20
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
20
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
21
ifneq (,$(parallel))
21
ifneq (,$(parallel))
22
jobsflag = -j$(parallel)
22
jobsflag = -j$(parallel)
23
endif
23
endif
24
24
25
config.status: configure
25
config.status: configure
26
	dh_testdir
26
	dh_testdir
27
	# Add here commands to configure the package.
27
	# Add here commands to configure the package.
28
	dh_autotools-dev_updateconfig
28
	dh_autotools-dev_updateconfig
29
	./configure $(buildflags) \
29
	./configure $(buildflags) \
30
		    --prefix=/usr \
30
		    --prefix=/usr \
31
		    --libdir=/usr/lib \
31
		    --libdir=\$${prefix}/lib \
32
	            --enable-shared \
32
	            --enable-shared \
33
	            --disable-dependency-tracking \
33
	            --disable-dependency-tracking \
34
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
34
	            CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
35
35
36
36
37
build: build-stamp
37
build: build-stamp
38
build-stamp:  config.status
38
build-stamp:  config.status
39
	dh_testdir
39
	dh_testdir
40
40
41
	# Add here commands to compile the package.
41
	# Add here commands to compile the package.
42
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
42
	$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
43
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
43
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
44
	$(MAKE) check
44
	$(MAKE) check
45
endif
45
endif
46
46
47
	touch build-stamp
47
	touch build-stamp
48
48
49
clean:
49
clean:
50
	dh_testdir
50
	dh_testdir
51
	dh_testroot
51
	dh_testroot
52
	rm -f build-stamp 
52
	rm -f build-stamp 
53
53
54
	# Add here commands to clean up after the build process.
54
	# Add here commands to clean up after the build process.
55
	[ ! -f Makefile ] || $(MAKE) distclean
55
	[ ! -f Makefile ] || $(MAKE) distclean
56
	dh_autotools-dev_restoreconfig
56
	dh_autotools-dev_restoreconfig
57
	dh_clean
57
	dh_clean
58
58
59
install: build
59
install: build
60
	dh_testdir
60
	dh_testdir
61
	dh_testroot
61
	dh_testroot
62
	dh_clean -k 
62
	dh_prep
63
	dh_installdirs
63
	dh_installdirs
64
64
65
	# Add here commands to install the package into debian/tmp
65
	# Add here commands to install the package into debian/tmp
66
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
66
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
67
67
68
# Build architecture-independent files here.
68
# Build architecture-independent files here.
-
 
69
build-indep:
69
binary-indep:
70
binary-indep:
70
# Nothing to do
71
# Nothing to do
71
72
72
# Build architecture-dependent files here.
73
# Build architecture-dependent files here.
-
 
74
build-arch: build
73
binary-arch: build install
75
binary-arch: build-arch install
74
	dh_testdir
76
	dh_testdir
75
	dh_testroot
77
	dh_testroot
76
	dh_install -a --sourcedir=debian/tmp
78
	dh_install -a --sourcedir=debian/tmp
77
	dh_link -a
79
	dh_link -a
78
	dh_installchangelogs -a ChangeLog
80
	dh_installchangelogs -a ChangeLog
79
	dh_installdocs -a
81
	dh_installdocs -a
80
	dh_installexamples -a
82
	dh_installexamples -a
81
	dh_installinfo -a
83
	dh_installinfo -a
82
	dh_installman -a
84
	dh_installman -a
83
	dh_strip -a --dbg-package=nettle-dbg
85
	dh_strip -a --dbg-package=nettle-dbg
84
	dh_compress -a -X.pdf
86
	dh_compress -a -X.pdf
85
	dh_fixperms -a
87
	dh_fixperms -a
86
	dh_makeshlibs -a
88
	dh_makeshlibs -a
87
	dh_installdeb -a
89
	dh_installdeb -a
88
	dh_shlibdeps -a
90
	dh_shlibdeps -a
89
	dh_gencontrol -a
91
	dh_gencontrol -a
90
	dh_md5sums -a
92
	dh_md5sums -a
91
	dh_builddeb -a
93
	dh_builddeb -a
92
94
93
binary: binary-arch
95
binary: binary-arch
94
.PHONY: build clean clean-patched binary-indep binary-arch binary install
96
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install