Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 53 | Rev 65 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
include /usr/share/dpatch/dpatch.make

# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)


CFLAGS = -Wall -g
LDFLAGS = -Wl,--as-needed

ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
else
        CFLAGS += -O2
endif
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
endif

config.status: ${DPATCH_STAMPFN} configure
        dh_testdir
        # Add here commands to configure the package.
        ./configure --host=$(DEB_HOST_GNU_TYPE) \
                    --build=$(DEB_BUILD_GNU_TYPE) \
                    --prefix=/usr \
                    --mandir=\$${prefix}/share/man \
                    --infodir=\$${prefix}/share/info \
                    --enable-shared \
                    --disable-dependency-tracking \
                    CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"


build: build-stamp
build-stamp:  config.status
        dh_testdir

        # Add here commands to compile the package.
        $(MAKE) MAKEINFO='makeinfo --enable-encoding'
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
        $(MAKE) check
endif

        touch build-stamp

clean: clean-patched unpatch
        dh_clean

clean-patched:
        dh_testdir
        dh_testroot
        rm -f build-stamp 

        # Add here commands to clean up after the build process.
        [ ! -f Makefile ] || $(MAKE) distclean

install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
        dh_installdirs

        # Add here commands to install the package into debian/tmp
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp

# Build architecture-independent files here.
binary-indep:
# Nothing to do

# Build architecture-dependent files here.
binary-arch: build install
        dh_testdir
        dh_testroot
        dh_install -a --sourcedir=debian/tmp
        dh_link -a
        dh_installchangelogs -a ChangeLog
        dh_installdocs -a
        dh_installexamples -a
        dh_installinfo -a
        dh_installman -a
        dh_strip -a --dbg-package=nettle-dbg
        dh_compress -a -X.pdf
        dh_fixperms -a
        dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a

binary: binary-arch
.PHONY: build clean clean-patched binary-indep binary-arch binary install