Subversion Repositories nettle

Compare Revisions

Ignore whitespace Rev 168 → Rev 169

/trunk/debian/patches/multiarch_dev.patch
26,15 → 26,3
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: make use of $ac_cv_header_stdint in $ac_stdint_h $ac_cv_stdint_result" >&5
$as_echo "make use of $ac_cv_header_stdint in $ac_stdint_h $ac_cv_stdint_result" >&6; }
--- a/version.h.in
+++ b/version.h.in
@@ -48,7 +48,8 @@ extern "C" {
/* We need a preprocessor constant for GMP_NUMB_BITS, simply using
sizeof(mp_limb_t) * CHAR_BIT is not good enough. */
#if NETTLE_USE_MINI_GMP
-# define GMP_NUMB_BITS @GMP_NUMB_BITS@
+# include <limits.h>
+# define GMP_NUMB_BITS (__SIZEOF_LONG__ * CHAR_BIT)
#endif
int