Subversion Repositories nettle

Compare Revisions

Ignore whitespace Rev 46 → Rev 47

/trunk/debian/patches/10_cleanup.dpatch
File deleted
/trunk/debian/patches/99_autotools_files.dpatch
File deleted
/trunk/debian/patches/01_config.dpatch
0,0 → 1,28
#! /bin/sh -e
## config.dpatch
## Ralf Treinen <treinen@debian.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: replace all config.{guess,sub} by the vesion installed in
## DP: /usr/share/misc
 
dpatch_patch ()
{
find . -name config.guess -o -name config.sub \
| tar cf debian/patched/config.guess+sub.tar -T -
find . -name config.guess \
-exec ln -sf /usr/share/misc/config.guess '{}' \;
find . -name config.sub \
-exec ln -sf /usr/share/misc/config.sub '{}' \;
}
 
dpatch_unpatch ()
{
tar xf debian/patched/config.guess+sub.tar
}
 
DPATCH_LIB_NO_DEFAULT=1
 
. /usr/share/dpatch/dpatch.lib.sh
 
# arch-tag: 8a610a57-687b-4395-8ff2-79265c0a4eb3
/trunk/debian/patches/30_sparc_aes_include.dpatch
0,0 → 1,57
#! /bin/sh /usr/share/dpatch/dpatch-run
## 30_sparc_aes_include.dpatch by Niels Möller <nisse@lysator.liu.se> and Magnus Holmgren <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Correct path to aes.m4 for sparc.
 
@DPATCH@
 
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- nettle/sparc32/aes-decrypt-internal.asm 2007/04/05 14:20:36 1.1
+++ nettle/sparc32/aes-decrypt-internal.asm 2007/09/08 08:48:41 1.2
@@ -18,7 +18,7 @@
C the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
C MA 02111-1307, USA.
-include_src(<sparc/aes.m4>)
+include_src(<sparc32/aes.m4>)
C Arguments
define(<CTX>, <%i0>)
diff -u -r1.1 -r1.2
--- nettle/sparc32/aes-encrypt-internal.asm 2007/04/05 14:20:36 1.1
+++ nettle/sparc32/aes-encrypt-internal.asm 2007/09/08 08:48:41 1.2
@@ -18,7 +18,7 @@
C the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
C MA 02111-1307, USA.
-include_src(<sparc/aes.m4>)
+include_src(<sparc32/aes.m4>)
C Arguments
define(<CTX>, <%i0>)
diff -u -r1.1 -r1.2
--- nettle/sparc64/aes-decrypt-internal.asm 2007/04/05 14:20:37 1.1
+++ nettle/sparc64/aes-decrypt-internal.asm 2007/09/08 08:48:41 1.2
@@ -24,7 +24,7 @@
C Use the same AES macros as on sparc32.
-include_src(sparc/aes.m4)
+include_src(sparc32/aes.m4)
C Arguments
define(<CTX>, <%i0>)
diff -u -r1.1 -r1.2
--- nettle/sparc64/aes-encrypt-internal.asm 2007/04/05 14:20:37 1.1
+++ nettle/sparc64/aes-encrypt-internal.asm 2007/09/08 08:48:41 1.2
@@ -24,7 +24,7 @@
C Use the same AES macros as on sparc32.
-include_src(sparc/aes.m4)
+include_src(sparc32/aes.m4)
C Arguments
define(<CTX>, <%i0>)
/trunk/debian/patches/00list
1,3 → 1,3
10_cleanup
01_config
20_link_with_gmp
99_autotools_files
30_sparc_aes_include
/trunk/debian/patches/20_link_with_gmp.dpatch
1,18 → 1,18
#! /bin/sh /usr/share/dpatch/dpatch-run
## 20_link_with_gmp.dpatch by <magnus@kibibyte.se>
##
## DP: Link libnettle.so.2 with -lgmp
## DP: Link libhogweed.so.1 with -lgmp
 
@DPATCH@
diff -urNad nettle-1.15~/config.make.in nettle-1.15/config.make.in
--- nettle-1.15~/config.make.in 2006-11-28 16:30:24.000000000 +0100
+++ nettle-1.15/config.make.in 2007-05-15 12:53:54.000000000 +0200
@@ -28,7 +28,7 @@
SHLIBFILE = @SHLIBFILE@
SHLIBFORLINK = @SHLIBFORLINK@
SHLIBINSTALL = @SHLIBINSTALL@
-SHLIBLIBS = @SHLIBLIBS@
+SHLIBLIBS = @SHLIBLIBS@ -lgmp
SHLIBLINK = @SHLIBLINK@
SHLIBMAJOR = @SHLIBMAJOR@
SHLIBMINOR = @SHLIBMINOR@
@@ -39,7 +39,7 @@
LIBHOGWEED_SONAME = @LIBHOGWEED_SONAME@
LIBHOGWEED_FILE = @LIBHOGWEED_FILE@
LIBHOGWEED_FORLINK = @LIBHOGWEED_FORLINK@
-LIBHOGWEED_LIBS = @LIBHOGWEED_LIBS@
+LIBHOGWEED_LIBS = @LIBHOGWEED_LIBS@ -lgmp -L. -lnettle
LIBHOGWEED_LINK = @LIBHOGWEED_LINK@
AR = ar