Subversion Repositories nettle

Compare Revisions

Ignore whitespace Rev 193 → Rev 194

/trunk/debian/rules
1,96 → 1,13
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
 
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
%:
dh $@
 
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
override_dh_installdocs:
dh_installdocs -a -Nnettle-bin
dh_installdocs -pnettle-bin --link-doc=libnettle8
 
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
buildflags = --build=$(DEB_BUILD_GNU_TYPE)
else
buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
override_dh_auto_configure:
dh_auto_configure -- --enable-fat
 
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
ifneq (,$(parallel))
jobsflag = -j$(parallel)
endif
 
config.status: configure
dh_testdir
# Add here commands to configure the package.
dh_update_autotools_config
./configure $(buildflags) \
--prefix=/usr \
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--enable-shared \
--disable-dependency-tracking \
$(shell dpkg-buildflags --export=configure)
 
build: build-stamp
build-stamp: config.status
dh_testdir
 
# Add here commands to compile the package.
$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(MAKE) check
endif
 
touch build-stamp
 
clean:
dh_testdir
dh_testroot
rm -f build-stamp
 
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
dh_clean
 
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
 
# Add here commands to install the package into debian/tmp
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
# Build architecture-independent files here.
build-indep:
binary-indep:
# Nothing to do
 
# Build architecture-dependent files here.
build-arch: build
binary-arch: build-arch install
dh_testdir
dh_testroot
dh_install -a --sourcedir=debian/tmp
dh_installdocs -a -Nnettle-bin
dh_installdocs -pnettle-bin --link-doc=libnettle8
dh_installchangelogs -a ChangeLog
dh_installexamples -a
dh_installinfo -a
dh_installman -a
dh_lintian -a
dh_strip -a
dh_compress -a -X.pdf
dh_fixperms -a
dh_makeshlibs -a -V
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
 
binary: binary-arch
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install