Subversion Repositories nettle

Compare Revisions

Ignore whitespace Rev 63 → Rev 64

/trunk/debian/rules
5,7 → 5,6
 
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
include /usr/share/dpatch/dpatch.make
 
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
12,7 → 11,6
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 
CFLAGS = -Wall -g
LDFLAGS = -Wl,--as-needed
 
25,9 → 23,10
INSTALL_PROGRAM += -s
endif
 
config.status: ${DPATCH_STAMPFN} configure
config.status: configure
dh_testdir
# Add here commands to configure the package.
dh_autotools-dev_updateconfig
./configure --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr \
50,10 → 49,7
 
touch build-stamp
 
clean: clean-patched unpatch
dh_clean
 
clean-patched:
clean:
dh_testdir
dh_testroot
rm -f build-stamp
60,6 → 56,8
 
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
dh_autotools-dev_restoreconfig
dh_clean
 
install: build
dh_testdir