Subversion Repositories nettle

Compare Revisions

Ignore whitespace Rev 64 → Rev 65

/trunk/debian/rules
11,16 → 11,15
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
CFLAGS = -Wall -g
LDFLAGS = -Wl,--as-needed
 
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
buildflags = --build=$(DEB_BUILD_GNU_TYPE)
else
CFLAGS += -O2
buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
 
parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
ifneq (,$(parallel))
jobsflag = -j$(parallel)
endif
 
config.status: configure
27,14 → 26,12
dh_testdir
# Add here commands to configure the package.
dh_autotools-dev_updateconfig
./configure --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) \
./configure $(buildflags) \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
--libdir=/usr/lib \
--enable-shared \
--disable-dependency-tracking \
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
 
 
build: build-stamp
42,7 → 39,7
dh_testdir
 
# Add here commands to compile the package.
$(MAKE) MAKEINFO='makeinfo --enable-encoding'
$(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding'
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(MAKE) check
endif
86,7 → 83,7
dh_strip -a --dbg-package=nettle-dbg
dh_compress -a -X.pdf
dh_fixperms -a
dh_makeshlibs #-V 'libnettle2 (>= 1.15)'
dh_makeshlibs -a
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a