Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 21 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
21 magnus 1
Description: Patch to bind to ipv6 socket as well
2
Author: Fabian Knittel <fabian.knittel@avona.com>
3
Bug-Debian: https://bugs.debian.org/533604
4
 
3 magnus 5
--- oidentd-2.0.8//src/oidentd_inet_util.c      2006-05-22 02:31:19.000000000 +0200
6
+++ oidentd-2.0.8.new//src/oidentd_inet_util.c  2010-03-01 20:26:11.000000000 +0100
7
@@ -60,6 +60,12 @@
8
 #ifdef WANT_IPV6
9
                case AF_INET6:
10
                        SIN6(ai->ai_addr)->sin6_port = listen_port;
11
+
12
+                       if (setsockopt(listenfd, IPPROTO_IPV6, IPV6_V6ONLY, &one,
13
+                                                       sizeof(one)) != 0) {
14
+                               debug("setsockopt IPV6_V6ONLY: %s", strerror(errno));
15
+                               return (-1);
16
+                       }
17
                        break;
18
 #endif
19