Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 22 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
22 magnus 1
Description: Change the configure script so that --enable-debug doesn't modify $CFLAGS
2
 The debug logging option is useful, but we don't want the build flags to be messed with.
3
 
4
--- a/configure
5
+++ b/configure
6
@@ -4533,7 +4533,7 @@ cat >>confdefs.h <<\_ACEOF
7
 #define ENABLE_DEBUGGING 1
8
 _ACEOF
9
 
10
-       DEBUG_CFLAGS="-O0 -fvar-tracking -g3 -ggdb"
11
+#      DEBUG_CFLAGS="-O0 -fvar-tracking -g3 -ggdb"
12
 fi
13
 
14
 enableval=""
15
--- a/configure.ac
16
+++ b/configure.ac
17
@@ -58,7 +58,7 @@ AC_ARG_ENABLE(debug,
18
 [  --enable-debug          Enable debugging])
19
 if test "$enableval" = "yes"; then
20
        AC_DEFINE(ENABLE_DEBUGGING, 1, [Define to enable debugging])
21
-       DEBUG_CFLAGS="-O0 -fvar-tracking -g3 -ggdb"
22
+#      DEBUG_CFLAGS="-O0 -fvar-tracking -g3 -ggdb"
23
 fi
24
 
25
 enableval=""