Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | Patch to bind to ipv6 socket as well |
2 | Patch supplied by Fabian Knittel <fabian.knittel@avona.com> |
||
3 | --- oidentd-2.0.8//src/oidentd_inet_util.c 2006-05-22 02:31:19.000000000 +0200 |
||
4 | +++ oidentd-2.0.8.new//src/oidentd_inet_util.c 2010-03-01 20:26:11.000000000 +0100 |
||
5 | @@ -60,6 +60,12 @@ |
||
6 | #ifdef WANT_IPV6 |
||
7 | case AF_INET6: |
||
8 | SIN6(ai->ai_addr)->sin6_port = listen_port; |
||
9 | + |
||
10 | + if (setsockopt(listenfd, IPPROTO_IPV6, IPV6_V6ONLY, &one, |
||
11 | + sizeof(one)) != 0) { |
||
12 | + debug("setsockopt IPV6_V6ONLY: %s", strerror(errno)); |
||
13 | + return (-1); |
||
14 | + } |
||
15 | break; |
||
16 | #endif |
||
17 |