Rev 3 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | Description: Fix a failure to build with gcc5. |
2 | Bug: http://bugs.debian.org/778035 |
||
3 | |||
4 | --- a/src/oidentd_util.c 2015-07-03 05:56:24.000000000 -0400 |
||
5 | +++ b/src/oidentd_util.c 2015-07-03 05:56:47.671378000 -0400 |
||
6 | @@ -75,7 +75,7 @@ |
||
7 | ** PRNG functions on systems whose libraries provide them.) |
||
8 | */ |
||
9 | |||
10 | -inline int randval(int i) { |
||
11 | +extern __attribute__ ((gnu_inline)) int randval(int i) { |
||
12 | /* Per _Numerical Recipes in C_: */ |
||
13 | return ((double) i * rand() / (RAND_MAX+1.0)); |
||
14 | } |
||
15 | --- a/src/oidentd_util.h 2015-07-03 05:56:32.000000000 -0400 |
||
16 | +++ b/src/oidentd_util.h 2015-07-03 05:56:53.835378000 -0400 |
||
17 | @@ -58,7 +58,7 @@ |
||
18 | int find_group(const char *temp_group, gid_t *gid); |
||
19 | |||
20 | int random_seed(void); |
||
21 | -inline int randval(int i); |
||
22 | +extern __attribute__ ((gnu_inline)) int randval(int i); |
||
23 | |||
24 | #ifndef HAVE_SNPRINTF |
||
25 | int snprintf(char *str, size_t n, char const *fmt, ...); |