Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 45 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 45 Rev 46
Line 114... Line 114...
114
+      pike_generate_seed_file();
114
+      pike_generate_seed_file();
115
+    RETURN ret;
115
+    RETURN ret;
116
   }
116
   }
117
 
117
 
118
   /*! @decl int(0..) needed_sources()
118
   /*! @decl int(0..) needed_sources()
-
 
119
diff -urad 7.6-stable~/src/post_modules/Nettle/testsuite.in 7.6-stable/7.8/src/post_modules/Nettle/testsuite.in
-
 
120
--- 7.6-stable~/src/post_modules/Nettle/testsuite.in	2007-06-18 02:43:51.000000000 +0200
-
 
121
+++ 7.6-stable/src/post_modules/Nettle/testsuite.in	2009-08-05 12:01:45.000000000 +0200
-
 
122
@@ -193,4 +193,14 @@
-
 
123
   }
-
 
124
 )
-
 
125
 ]])
-
 
126
+
-
 
127
+cond_resolv( Nettle.Yarrow, [[
-
 
128
+  test_any_equal([[
-
 
129
+    object y = Nettle.Yarrow()->seed("What happen? Somebody set up us the bomb.");
-
 
130
+    return ({ y->get_seed(), y->random_string(20), y->get_seed(), y->random_string(20) });
-
 
131
+  ]], [[({String.hex2string("73a35b2f896a8061be0ad434a592a43a82b81b9ed6c018f1c5a51300bbc8d53d"),
-
 
132
+	  String.hex2string("7847458e32fb789ff6b6cd6e1c8cc3712ba532a8"),
-
 
133
+	  String.hex2string("73a35b2f896a8061be0ad434a592a43a82b81b9ed6c018f1c5a51300bbc8d53d"),
-
 
134
+	  String.hex2string("49a090656a6d93782e169994f41005a3616d3cd7")})]])
-
 
135
+]])