Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 02_smartlink_rpath.dpatch by  <magnus@proffe.kibibyte.se>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Make smartlink not use -rpath
6
 
7
@DPATCH@
8
 
9
--- pike7.3-7.3.51.orig/bin/smartlink
10
+++ pike7.3-7.3.51/bin/smartlink
11
@@ -147,9 +147,8 @@
12
      LDOPTS="$LDOPTS -R$RPATH"
13
    ;;
14
    Linux\ 2.*)
15
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
16
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
17
-     fi
18
+     LD_LIBRARY_PATH="$RPATH"
19
+     export LD_LIBRARY_PATH
20
    ;;
21
    UnixWare\ 7.*)
22
      if test x$LINKING != xno -a "x$RPATH" != x ; then
23
--- pike7.5-7.5.3/src/smartlink.c.orig	2003-01-17 20:13:38.000000000 +0100
24
+++ pike7.3-7.5.3/src/smartlink.c	2003-03-20 16:58:02.000000000 +0100
25
@@ -146,7 +146,7 @@
26
   full_rpath = rpath;
27
 
28
 #ifdef USE_Wl
29
-  strcat(rpath, "-Wl,-rpath,");
30
+  /* strcat(rpath, "-Wl,-rpath,"); */
31
 #elif defined(USE_Wl_R)
32
   strcat(rpath, "-Wl,-R");
33
 #elif defined(USE_R)
34
@@ -258,7 +258,7 @@
35
     }
36
     rpath_in_use |= add_path(rpath, ld_lib_path);
37
   }
38
-
39
+#if 0
40
   if (rpath_in_use) {
41
     /* Delete the terminating ':' */
42
     rpath[strlen(rpath) - 1] = 0;
43
@@ -305,6 +305,7 @@
44
 #error Unknown method
45
 #endif
46
   }
47
+#endif
48
 
49
   new_argv[new_argc++] = NULL;
50