Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 04_make_variables_fpic.dpatch by  <magnus@proffe.kibibyte.se>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Add -fPIC to OTHERFLAGS and NOOPTFLAGS in src/make_variables.in
6
 
7
@DPATCH@
8
 
9
--- pike7.6-7.6.27/src/make_variables.in	2004-04-23 17:41:33.000000000 +0200
10
+++ pike7.6-7.6.27.new/src/make_variables.in	2005-06-18 04:19:00.278899432 +0200
11
@@ -26,8 +26,8 @@ RUNPIKE=$(@RUNPIKE@)
12
 OPTIMIZE=@OPTIMIZE@
13
 INSTALL=@INSTALL@
14
 WARN=@WARN@
15
-OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL)
16
-NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL)
17
+OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL) -fPIC
18
+NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL) -fPIC
19
 AR=@AR@
20
 SRCDIR=@srcdir@
21
 PMOD_TARGETS=@PMOD_TARGETS@