Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 2 Rev 3
Line 3... Line 3...
3
##
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Allow include_prefix to be separately overridden in install.pike
5
## DP: Allow include_prefix to be separately overridden in install.pike
6
6
7
@DPATCH@
7
@DPATCH@
8
-
 
9
--- 7.6/bin/install.pike	2005-12-30 14:33:48.450200000 +0100
-
 
10
+++ 7.6.fix/bin/install.pike	2005-12-30 15:14:24.806462750 +0100
-
 
11
@@ -1197,7 +1197,7 @@ int pre_install(array(string) argv)
8
diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
12
       exec_prefix=combine_path(prefix,"bin");
-
 
13
       lib_prefix=combine_path(prefix,"lib");
-
 
14
       doc_prefix=combine_path(prefix,"doc");
-
 
15
-      include_prefix=combine_path(prefix,"include","pike");
-
 
16
+      include_prefix=vars->include_prefix||combine_path(prefix,"include","pike");
-
 
17
       man_prefix=combine_path(prefix,"man");
-
 
18
       if (export) {
-
 
19
 	low_install_file(combine_path(vars->TMP_BINDIR,"install.pike"),
-
 
20
--- 7.6.orig/src/Makefile.in	2005-07-28 01:19:28.618585000 +0200
9
--- trunk~/src/Makefile.in	2006-10-20 15:40:28.000000000 +0200
21
+++ 7.6/src/Makefile.in	2005-08-16 12:53:13.127535720 +0200
10
+++ trunk/src/Makefile.in	2007-09-26 09:51:13.000000000 +0200
22
@@ -53,7 +53,7 @@ man_prefix = $(prefix)/man
11
@@ -53,7 +53,7 @@
23
 # TESTARGS = -F -a
12
 # TESTARGS = -F -a
24
 
13
 
25
 # Arguments for install.pike used by the install targets.
14
 # Arguments for install.pike used by the install targets.
26
-INSTALLARGS = --new-style
15
-INSTALLARGS = --new-style
27
+INSTALLARGS ?= --new-style
16
+INSTALLARGS ?= --new-style
28
 
17
 
29
 #
18
 #
30
 # use bison please, yacc isn't good enough.
19
 # use bison please, yacc isn't good enough.
31
@@ -495,7 +495,7 @@ install: pike tools
20
@@ -506,7 +506,7 @@
32
 	MANDIR_SRC="$(MANDIR_SRC)" \
21
 	MANDIR_SRC="$(MANDIR_SRC)" \
33
 	man_prefix="$(man_prefix)" pike_name=$(pike_name) \
22
 	man_prefix="$(man_prefix)" pike_name=$(pike_name) \
34
 	fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
23
 	fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
35
-	$(INSTALLARGS)
24
-	$(INSTALLARGS)
36
+	include_prefix="$(include_prefix)" $(INSTALLARGS)
25
+	include_prefix="$(include_prefix)" $(INSTALLARGS)